Unable to claim markone beacon

I tried to claim the photon device through my phone but was encountered with this error on the particle app.

I also tried to claim the photon markone through my odroid XU4 using Ubuntu 16.04(Linux)
Here’s the steps which i follow closely to claim the photon: https://irlock.readme.io/v1.0/docs/claiming-a-markone-device and https://irlock.readme.io/v1.0/docs/connecting-to-wifi-access-point. However i faced issue at the particle identify and particle serial wifi whereby it called me to reinstall the CLI as shown below.

I tried to reinstall the nodes and npm but to no avail. Hope that yall can help me up with this!
Thanks alot!

In order to claim your device the WiFi network you are attaching it to has to have internet access. Does your Markone Beacon provide that? I doubt it.

What you want is to claim the Photon by connecting it to a internet connected WiFi.
After you have claimed the device you can then just hook the already claimed device up with any other WiFi network without going through the claiming process again.

Since you now already have the WiFi creds for your Markone Beacon stored, just switch of that network, put the Photon back into Listening Mode (without clearing the credentials tho’) and go through the setup process again but this time with a “proper” WiFi connection :wink:

BTW, if you cleared the WiFi credentials you can always reapply them via Listening Mode and CLI particle serial wifi.

1 Like