Tutorial: Installing the Particle Workbench developer preview

Ctrl/Cmd+Shift+B should bring up the Build commands.


I already had a tasks.json in my project, so the new extension didn’t overwrite it. which in turn meant that nothing was happening.

I tried it out on a different project that doesn’t have the tasks.json file in the project and I have the build menu appearing now.

I think that this is going to be great, when it’s all working - still a bit of playing for me to get it going.

c:\path\main.h:32:21: error: ‘Serial5’ was not declared in this scope

Do I need to download the source files of the libraries and include them? (as opposed to Particle Dev’s properties)

So whats the best link, thread to be watching to get all the latest updates on this?

When it was installing I noticed ver 0.7.0 was being downloaded. Are we forced to use 0.7.0? I can’t use that version as it causes my application problems. I still use 0.6.3.

After installation I opened a folder to a project but have no clue what to do next.
Tried the

But that brings this up which IMHO means nothing to me.


I’ve installed Workbench and I’m looking under the hood of it now.

Everything is kept in ~/.particle and it is very well organized. (Like po-util but done professionally.)

I’ll definitely see if I can make some scripts to build upon Workbench.


Nice! So, with a little help from Particle folks, I learned that the next step after installing was to use the MSCode Command Palette (Ctrl-Shift P) to invoke, “particle: create new project”

Once I brought in some code that runs on the Photon, I used the Build menu to kick off a build. It builds. Rah.

This will be great particularly when I break the network stack and the web IDE isn’t available for an update (…without device reset).

Looking forward to more walkthroughs from you


9 posts were split to a new topic: Issues installing Workbench’s VSIX (combined from multiple threads.)


Particle: Install Library will have to do both. For cloud build it will use the project.properties dependencies but for local build it needs a local copy of the sources.

1 Like

You have set the platform as Electron?

Check for "particle.targetPlatform": "electron" in yourProject.code-workspace

Have you added the required include statement as noted in the reference docs?

Switching versions is easy (although it may become even easier in future)
Open yourProject.code-workspace and change "particle.firmwareVersion": "0.7.0" to "particle.firmwareVersion": "0.6.3" and save.
This should download the required sources and set you up for local compiling of all modules too.

This is what I get with Ctrl/Cmd+Shift+B

But of course the keyboard shortcut needs to be set correctly

Which should be done by the VSIX (requires reload).

Are the release candidates of 0.8.0 supported? I’ve tried a few permutations of 0.8.0-rc.11 but says it’s invalid.

1 Like

See this earlier post

But I’m sure efforts will be made to also support RCs.

In the command palette when you set your target device, if you are logged in, should it not show your devices? As opposed to having to know the device name or device ID and type it in?

2 posts were split to a new topic: Issues installing compiling (combined from multiple threads.)

FWIW, what I did (and worked) was:
Click gear icon bottom left, select Command Palete, enter “particle” and select Particle: Install local compiler from the drop-down list.

Hi, my project compile and working well. Here is project build step with my library.


It’s alpha so appreciate that it’s still a bit flaky at the moment, but hopefully this will provide a solid more co-herent platform for development and debugging.

So are we able to open existing projects or do we need to start from scratch by creating a project and then importing previous files, anything I open existing is not working.

Also, will it handle building of library projects or are we at the moment just at the firmware level ?

Currently there is no one-click way to migrate existing projects, but something that way is planned.
For now you’d need to create a new project and copy your sources into that.

Same goes for library creation. It’ll come.


Thanks @ScruffR

Suspected that would be the case. Looks good so far.

As a professional developer with Microsoft Technologies I am so used to Visual Studio and everything being nicely tied together and am really missing a nice co-herent development experience.

So keep at it guys, hopefully this will progress rapidly to a really good building process, which is a bit lacking at the moment. WebIDE is nice but lacks the GIT integration. Desktop with ATOM is good but lacks coherence.

So really hopefull with viscose as a way forwards. Looking forward to trying debugging.

Keep at it



A post was split to a new topic: 2 factor auth support