Trouble flashing the code OTA and via USB

Hi,
I have set up my Argon. OTA fash from IDE does not work although it says flash was successful I am simply trying to make the Blink LED code example run but I get no outputs from serial monitor nor the output pins D7 and D0.

I have tried to upload the code via CLI but I get the following error:

attempting to flash firmware to your device xxxx
Flash device OK: timed out waiting for device to start

or sometimes this: lash device failed: Request Timed Out

I would appreciate any help. Thanks

Is your device breathing cyan while you try flashing?
Can you try OTA while in Safe Mode?
When trying to flash via CLI which command are you using and in what mode was the device at the time?

Which IDE (Web IDE or Workbench)?
What device OS version are you targeting and which have you got on your device?

1 Like

No it is in listening mode.

I will try this now and get back to you.

particle flash (my device name) program.ino

or

particle flash (my device name) program.bin

Web IDE

1.1.0

Thank you in advance

I was unable to put the device in the safe mode. It gets stuck on the listening mode or goes to DFU mode if I hold the mode button too long.

You cannot OTA update while in Listening Mode since that means no cloud connection.
It needs to be breathing cyan or magenta.

That would suggest you either haven’t got any valid WiFi credentials stored or you haven’t finished the setup procedure via the mobile app at all.

1 Like

I could not use the app for the setup so I had to set it up manually. I have managed to get the device recognized by the app and managed to flash the code successfully through web IDE thanks to your help but it seems like the code is not running on device.
I get no outputs from pins and serial (I have added some serial messages to the example Blink code for purpose of testing the serial monitor). I don’t know what could be the problem.

Why what that? What happened?

How did you do that?

What code are you running?

Is the device now breathing cyan?

1 Like

I have managed to run the code now. I tried the app setup with another phone that could scan the code and now everything is fine.

Using Particle CLI I flashed “argon-bootloader@1.1.0.bin” , “argon-system-part1@1.1.0.bin” and “argon-tinker@1.1.0.bin” and “argon-ncp-firmware-0.0.5-ota.bin” files in their respective specified device modes.
Then followed the steps for Mesh setup over USB(https://docs.particle.io/support/particle-devices-faq/mesh-setup-over-usb/)
The device was showing in the app but oddly not working. I may have missed some steps.