Trouble Flashing over Serial and using Listening Mode

Hi Community,

I have been using the Electron for a year now and have traditionally used the flash over serial method. I’ve recently come into a roadblock after powering up the Electron and now the LED does not breathe light blue but rather is a solid light blue.
When I press the “MODE/SETUP” button to upload to my device, nothing happens. Earlier in the day today I also had issues with my Electron not being connected to the COM port (although it is successfully connected)
I have also isolated the issue to the board level, as I have tried flashing it over cellular and was not successful with this method.

Any help would be much appreciated.
Thx, Mike

The solid cyan LED suggests a deadlock most likely produced by user code.
To get around that you could try Safe Mode or particle flash --usb tinker -v to remove the currently running application.

Hi Scruff,
Thanks, I was finally able to remove the application through safe mode. Do you know where I can find a guide to the particle flash command line utility?

Here is the CLI reference:

Thanks Ninjatill! Have you also worked with casting variables as different types? I’m about to start a separate thread that I could use some help on.

Yes. I have some experience casting data types. A new thread would be best for that non-related topic.

It would be great if you could take a look at it. Link is here: