TI SmartConfig Android Application and Spark core


I’m trying to set the FirstTimeConfig with the TI app.

1.I’m clearing the wifi settings (10 sec press on the mode button) and trying to connect with the TI smart config app. First, sometimes it seems that the core doesn’t get the msg (staying in flashing blue). Sec, sometimes, when I do it with the TI APP it staying in “flashing green” and not moving forward in the process. Do you know this? What can i do?

  1. Does the device name in the TI APP matters for the process?

  2. Can I do the smart config from different phones/users while it is already register for another user?

Best regards,

No one has experience with the TI SMART CONFIG?

Nobody did the Smart config with his own smartphone application?

Hey @zachary,

Sorry that I’m popping up this post with again with your name, but do you have an answer?

Hi @itayd100, if you use the TI app, the device name must be CC3000 and the AES key must be sparkdevices2013. See the firmware values here:

When the Core stays flashing blue and never seems to get the message, then most likely your phone is speaking with the router over 802.11n on the 5GHz frequency band. The Core is listening on 2.4GHz.

The process of sending Wi-Fi credentials using Smart Config is completely separate from the claiming process. Anyone, on any device, can Smart Config a Core if it is in listening mode, no matter who has claimed the Core. Once the Core is online, only the person who has claimed the Core can call functions, send OTA firmware updates, etc.

If you’re still having trouble, be sure to go step-by-step through the troubleshooting guide here:


1 Like


It seems itayd100 never got it working as he was telling me in the following post.

Zachary, could you confirm that the device name and AES key are still the same ? should we try “sparkdevices2014” ?
Do we need to use a special software revision to have it working ? (I have the spark core v1.0 who was shipped a few weeks ago).

What informations should I give you in order to nail this issue ?

Thank you.

I had not used the “SimpleLink™ Wi-Fi® Starter” app from Texas Instruments Inc. in a long time, so I just downloaded it onto my Android phone and tried it with a Core. It did not work.

Also, I noted that the splash screen indicated the app was specifically for CC3100 and CC3200 devices, not CC3000. This leads me to believe that TI no longer supports the CC3000 with an Android mobile app.

It appears that the only options for Smart Config from a mobile device may be to use the Spark app or build your own app using TI’s libraries, as we have.

The device name and AES key have not changed. You can see them in the code:

Here are our open source apps in case it helps:


I can see above Zachary hasn’t been able to use an app on an android device. I just managed to get mine to work for the first time by downloading the sample app from here…


I opened the app in android studio and passed it to my non-virtual android device and it worked fine. So that version of the app must still be compatible with CC3000.

1 Like