Taking forever to connect to the network

So I got my core today and was following along with everything to get it setup, but it seems that it takes forever to connect to the network, when it does forever. I have managed to get it to connect and upload some sample code, but when it connects it seems to take 5-15 minutes to connect which is horribly slow considering I am sitting next to a laptop, cell phone, and Roku box that are all on the same network.

All I am doing is staring at a flashing green light … (as a side note, a different indicator might be in order as there are some of us who cannot tell the difference between the colors due to color blindness and it saves a lot of troubleshooting not to have to rely on others to ask 'what color is this light?).

Any ideas what I could be doing differently? It does connect sometimes, just often very slowly …

Did you managed to claim the core yet?

I did (using the USB method on Windows), I even managed to flash code on it a couple times, but when it works its

Flash, wait, hope it connects, test, flash…

And wait, when it works can literally be 10 minutes it more when it works.

interesting! Sounds like you managed to connect successfully to the :cloud:.

Can you flash an empty firmware and see if that’s the same behavior observed?

I can try in the morning, of course at the moment it is simply not connecting so I’ll have to maybe reset it out something.

1 Like

So I spent the morning trying different things.

I tried a factory reset, no luck.

I tried two different access points, an Apple Airport Extreme and a UBEE DVW3200 (Cable Modem/Wireless Router in one). On each I’ve tried a combination of WPA and WPA2 with the different access points and passcodes (using the USB set up method from Windows to set it).

Last night it would occasionally connect, but now it is not connecting at all.

I forgot to mention that I also tried setting it approximately a 2 feet from the access points, still nada.

Hi @nicholasstg,

Can you send us a video of your core trying to connect by chance?


I would except, of course it just started working …

The only thing I changed is that I noticed that the SID for the UBEE was capitalized in the access point settings (Metropolis vs metropolis) and I was not doing that when setting up the core. I made that change and it seems to be connecting and flashing fairly instantly.

I’m not ready to throw up my hands and yell success over something so minor just yet yet, but pretty close.

And everything seems to be fine now after a week.

1 Like