Stuck in listening mode


#1

I was trying to get all of my source code into git repositories and did some recompiles and flashes to upgrade a couple devices to 0.7.0 since 0.6.4 went away. I’m now having problems getting them online. One of them seems to be stuck in listening mode. I’ve tried flashing Tinker (over USB), but without any benefit.

I’m feeling rather dimwitted, as I’ve been deploying these devices for quite some time.

I should mention that on one of the devices, I tried to go to 0.8.0 and then tried to go back down, but without success.

I really need to get back to a safe place and then start the march back up to 0.7.0.

One of the way the problems manifested themselves is in not exposing any published variables or functions.


#2

so…I’m running particle firmware manager 0.6.0 and hope to then flash Tinker 0.6.0. I believe this worked in the past. I don’t quite understand the whole boot loader issue and when I need to worry about upgrading/downgrading it.


#3

Using the 0.6.0 firmware manager, I was able to get back to 0.6.0, but had to re-add my WiFi credentials for some reason. I suspect it has to do with having tried going to 0.7.0 directly from 0.6.0. I had already recompiled my application for 0.6.0. I’m now afraid to move forward to 0.7.0. I had previously always settled on 0.6.4, but it’s nowhere to be found, so I’m at a bit of a loss having seen some issues related to 0.7.0.

This whole OS upgrade/downgrade process needs a bit better documentation. I realize I can read through the posting about new system firmware, but it’s a bit ridiculous that it’s so easy to break and then so tough to figure out how to get out of trouble.


#4

What do you mean by that?

Unless you want 0.6.4 for the Photon - that did never exist.
0.6.3 it the most recent 0.6.x version for Photons while there is no 0.6.3 for Electrons, but 0.6.4 is the most recent 0.6.x for these devices.


#5

I’ve been working with Electrons mostly as of late, so I guess that’s why it appeared to be missing.

Now, when I try to flash new code to my device, it doesn’t appear to get there and I noticed the following message in the console:
{“data”:"{“service”:{“device”:{“status”:“invalid”},“coap”:{“round_trip”:83},“cloud”:{“uptime”:0,“publish”:{“sent”:1}}}}",“ttl”:60,“published_at”:“2018-07-12T19:54:56.011Z”,“coreid”:“37001f001747343337363432”,“name”:“spark/device/diagnostics/update”}

I’m concerned about the “status” item. Does that indicate a problem for me?


#6

Since the status field will only by populated with v0.8.0+ you shouldn’t pay much attention to it on devices not running 0.8.x or greater.


#7

One other change I made today…I installed SourceTree on my Mac and have put all of my development folders into git as repositories. Can that have any impact on how code is compiled?


#8

How are you building your projects?


#9

I use Particle Dev almost of the time except for my legacy applications. I’ve always believed it was the preferred environment, but would love to know if you feel otherwise. With git now implemented via SourceTree, it really seems like the preferred environment for development.

What surprised me was Dev showing branch information at the bottom of the screen and it made me wonder if there could be a side effect from implementing git. However, I tried git with another simple app and it seemed to have no impact. Thought it was worth asking.

I’m going to remove the delay at the beginning of setup() as @Moors7 had suggested. It is a remnant of an older version and is really superfluous. That being said, I’ll post back the results of that change. As I recall, it was there to allow me to start up a device and have time to get particle monitor up and running via the CLI.


#10

Particle Dev is rather picky when it can see more than one project from the directory you are building from.
Make sure you organise each project in your project tree as a leaf (no nested branches) and explicitly select that leaf when you are opening the project you want to work with via Open Folder ....
It is a common misconception that selecting a file or folder in the tree view panel of Dev would set this project as the target project. After all, Dev is actually just an Atom based text editor without any concept of a project structure, with some extra packages which rely on the user to tell them what the project base is via the respective menu item File - Open Folder ...

That’s very much a personal choice - I don’t use Dev at all - unless to check on issues members have with it.
I do most my quick and dirty projects in Web IDE and the more involed stuff or library programming I do with CLI.