Spark core not responding. Only small blue LED is on


Hi @d82k,

If the core goes blank like this after a flash, try a factory reset:



My core is flashing only blue LED, before this it even got connected to the cloud and I even did a project but now it’s not even able to get connected to the wifi. What to do?


@anirudh - You may need to try to reboot and clear memory to clear out the stored wifi networks. You will need to go through the wifi setup process using Tinker or the Spark CLI after the wifi wipe.

If that doesn’t work, try a factory reset. If that still doesn’t work, we can still dig deeper!


Just wanted to add that after a bad flash, i too had a completely blank core with nothing except the tiny (D7) blue led flashing intermittently.

I tried the “factory reset” - but the first few times i tried it it didn’t work, but eventually it did.

I’m re-writing the instructions here in case it helps anyone understand the process better:

  1. Keep the MODE & RST buttons pressed down together (the tiny blue LED will be constantly lit)
  2. Release the RST button but – continue to keep the MODE button pressed
  3. Wait a few seconds
  4. The main LED will start to flash Yellow – continue to keep the MODE button pressed
  5. The main LED will go blank – continue to keep the MODE button pressed
  6. The main LED will turn solid white – continue to keep the MODE button pressed
  7. The main LED will start to flash white – you can finally release the MODE button!

Your spark should start flashing blue now.

Don’t forget, you’ll need to re-connect your core to Wifi (using the “+” button in the app) just like you did when you first got it…




What you described is basically the procedure for Factory reset no?

It’s the same as: but thanks for making it clearer! :wink:


Yes, as mentioned, i just re-wrote it for easier understanding – and so that less people have to email you / ask for replacements etc. I came pretty close to that today, so thought I’d clarify here as well (since this thread is indexed better on google) as well as say “it worked!” to give others hope :wink:

Honestly, i hadn’t ever managed to come across that video you linked to (also it didn’t seem to play for me). The docs are shaping up nicely, and the long pages are great for “reading and learning”, but unfortunately they are not the most efficient when you’re searching for something specific, or are viewing them for the first time. I’m sure the format of that section will improve over time.




following your steps, i have pushed it to Docs.

see here:

Thanks! :wink:


Some one please help me out, my core is blinking only blue colour, what to do? I did factory reset like 100 times, Reply ASAP.


Blinking blue?

It means that your core is in Listening Mode. Can you send Wifi Crendentials using USB or the Mobile apps? :wink:


I am getting the same problem even after a factory reset (several factory resets :(). In the troubleshooting guide it says that it may be missing firmware that is why the small dim blue LED. Is there something with the web IDE that perhaps I should add to my code when I re-flash? I have tried different code including the example “blinking an LED” with the same result


I can test if you have some test code.

Have feedback to Spark HQ and let’s see what they say.


I thought it was my code but I tested with the example “Blink an LED”, and the same thing happens. I successfully re-flash OTA but then 3/4 of the way during the re-flash, the main LED goes dark and the small LED dims blue. I am able to get Tinker after a factory reset but that is it.


Hi kennethlimcp,
the web IDE now works for me this AM! Strange, I changed nothing and it works :smile:


Glad to hear it’s working. The Spark Gods must look favorably on you today! :slight_smile:


I’m having the same problem as others here. As soon as a apply power to the photon, D7 goes solid blue, and stays solid blue, not matter what I try. Factory reset doesn’t work (after many attempts, and I am certain I’m doing it correctly). Safe mode doesn’t work. The photon, which is brand new, did work correctly initially. I was able to flash a couple of programs on to it. It was during a flash that this behavior (or lack thereof) started. I also noticed that the photon was very hot. I was powering it from the USB port of my Raspberry Pi. I have tried powering it from a variety of sources, to no avail. Help and suggestions please! :).



We’ve deployed a product with good success, but this D7 issue has shown up in a few of our kits. They were factory tested before going out, and there are many other units with the exact same firmware throughout the world now that work fine.


  1. D7 stays on consistently when the unit is powered up.
  2. Safe mode and WiFi reset don’t work
  3. The main LED does not respond to any sequence of button taps we’ve tried.


We don’t want to have to connect the unit via USB, because we would have to ask customers to unscrew the board from the enclosure to do that. Hopefully there’s an easier fix.

Thanks for any help you can provide,


Unfortunately a Dim D7 is caused by an erased bootloader and can only be fixed by JTAG or SWD. It can’t even be fixed by USB.

The lost keys, lost settings, and lost boot loader may be variations of this problem:

When some situation, it tends to be a low-power brown-out type of situation, occurs, it appears that certain flash sectors can be erased. Sometimes, it’s the sector that contains settings (like Wi-Fi settings or device keys), and sometimes it’s the boot loader.

When the boot loader gets erased, the only thing that happens is the blue D7 LED will light dimly, and it will not respond to other buttons. When this happens, we typically replace the device, though developers can typically fix it with JTAG/SWD programmer.

This has a tendency to occur on Electrons mainly because more of them operate on battery power. It can also occur on Photons. It has also been seen on a RedBear Duo. All of these devices have similar STM32F205 processors, however. It also is not specific to battery power, it can happen when using a power adapter as well, though much less frequently. Using old phone chargers with loose USB connectors is the most likely scenario for powered devices.

Also, it’s not simply running at a low voltage. The processor has protection for that, and we’ve tried running the devices at all voltage levels and can’t make the problem happen. It appears to be some combination of factors that is quite elusive.

For battery powered devices, the best workaround until the problem is solved is to make sure you don’t run until the power goes completely out. Instead, use sleep modes to conserve power until sufficient power is available again.

Dead Photon with Led D7 On

I have the same problem of a frozen Electron with the blue dim D7 LED. If I’m following all the posts, this has been an issue for over 1.5 years–please correct me if I’m wrong on that. My electron was working well (with the occasional need to reset) for a year. It was getting a clean power source 5.2v from a DC/DC buck converter that was in tern connected to a 12v generator battery that was connected a trickle charger. I don’t think the only reason is related to discharged batteries/brown outs, or it would be very easy to duplicate. Is it possible that it is the opposite problem related to static electricity. To confirm the only solution is to replace the electron?


I use an inexpensive ST-LINK/V2 Mini SWD USB stick, about US$15 from Amazon but available elsewhere as well. That combined with the JTAG programming instructions will allow you to reprogram the device and usually get it working again,

But you do not have to do this; you can create a support ticket and after a little more troubleshooting to verify that’s indeed the problem you can get a replacement device.


Thank you for the reply.