Spark core not responding. Only small blue LED is on


#15

Yes, send your shipping information to hello at spark dot io, we’ll send you a self-addressed envelope to return the non-functional Core. Thanks!


#16

I sent an e-mail to hello@ 5 days ago regarding the same issue and haven’t received a response other than the auto-responder. I’m not sure if a forum post is the right place for it, but the forums seem to be more active/faster than an e-mail inbox.


#17

Just wanted to make sure you heard back on this; did you get a response from hello@?


#18

Nothing since the auto-responder on 1/2. I’ve been keeping a close eye on my spam folder, too. With everyone out of the office this past week, I wasn’t going to harp on it yet!


#19

Oops, looks like we marked your email as ‘resolved’ for some reason! Just sent you an email to follow up, sorry about the delay.


#20

Ok! I guess my Core is dead as I can only see a small Blue LED while the Core RGB LED is off. I’ve mailed support.


#21

Hello,
I have the same issue, I was flashing the core with my code it was blinking purple that it reset, and now I just have the small blue led on and the RGB led off and nothing happens even if I push buttons.
Does anyone of you was able to solve this issue?
Thank you,
dk


#22

Hi @d82k,

If the core goes blank like this after a flash, try a factory reset: http://docs.spark.io/#/connect/appendix-dfu-mode-device-firmware-upgrade

Thanks!
David


#23

My core is flashing only blue LED, before this it even got connected to the cloud and I even did a project but now it’s not even able to get connected to the wifi. What to do?


#24

@anirudh - You may need to try to reboot and clear memory to clear out the stored wifi networks. You will need to go through the wifi setup process using Tinker or the Spark CLI after the wifi wipe.

If that doesn’t work, try a factory reset. If that still doesn’t work, we can still dig deeper!


#25

Just wanted to add that after a bad flash, i too had a completely blank core with nothing except the tiny (D7) blue led flashing intermittently.

I tried the “factory reset” - but the first few times i tried it it didn’t work, but eventually it did.

I’m re-writing the instructions here in case it helps anyone understand the process better:

  1. Keep the MODE & RST buttons pressed down together (the tiny blue LED will be constantly lit)
  2. Release the RST button but – continue to keep the MODE button pressed
  3. Wait a few seconds
  4. The main LED will start to flash Yellow – continue to keep the MODE button pressed
  5. The main LED will go blank – continue to keep the MODE button pressed
  6. The main LED will turn solid white – continue to keep the MODE button pressed
  7. The main LED will start to flash white – you can finally release the MODE button!

Your spark should start flashing blue now.

Don’t forget, you’ll need to re-connect your core to Wifi (using the “+” button in the app) just like you did when you first got it…

Cheers,
R


#26

@Rehaan,

What you described is basically the procedure for Factory reset no?

It’s the same as: http://docs.spark.io/connect/#appendix-factory-reset but thanks for making it clearer! :wink:


#27

Yes, as mentioned, i just re-wrote it for easier understanding – and so that less people have to email you / ask for replacements etc. I came pretty close to that today, so thought I’d clarify here as well (since this thread is indexed better on google) as well as say “it worked!” to give others hope :wink:

Honestly, i hadn’t ever managed to come across that video you linked to (also it didn’t seem to play for me). The docs are shaping up nicely, and the long pages are great for “reading and learning”, but unfortunately they are not the most efficient when you’re searching for something specific, or are viewing them for the first time. I’m sure the format of that section will improve over time.

Cheers!
R


#28

@Rehaan,

following your steps, i have pushed it to Docs.

see here: http://docs.spark.io/connect/#appendix-factory-reset

Thanks! :wink:


#29

Some one please help me out, my core is blinking only blue colour, what to do? I did factory reset like 100 times, Reply ASAP.


#30

Blinking blue?

It means that your core is in Listening Mode. Can you send Wifi Crendentials using USB or the Mobile apps? :wink:


#31

Hello,
I am getting the same problem even after a factory reset (several factory resets :(). In the troubleshooting guide it says that it may be missing firmware that is why the small dim blue LED. Is there something with the web IDE that perhaps I should add to my code when I re-flash? I have tried different code including the example “blinking an LED” with the same result
Thanks!


#32

I can test if you have some test code.

Have feedback to Spark HQ and let’s see what they say.


#33

Hi,
I thought it was my code but I tested with the example “Blink an LED”, and the same thing happens. I successfully re-flash OTA but then 3/4 of the way during the re-flash, the main LED goes dark and the small LED dims blue. I am able to get Tinker after a factory reset but that is it.


#34

Hi kennethlimcp,
the web IDE now works for me this AM! Strange, I changed nothing and it works :smile: