[Spark core] Common issues

I’m unable to configure to DFU mode as i have tried by pressing mode and rst button and released rst button and waited until it blinks yellow and i have entered the particle flash --usb cc3000 but i have got C:\Users\raviteja>particle flash --usb cc3000
Apparently I didn’t find a DFU device? util sa
Error writing firmware… no dfu device found.
what should i do now!!

Bump, I’m having the same issue with an older Spark Core. I was able to revive another old Spark a different way… but I can’t get it to work this way.

What steps have you taken?

Hello again @kennethlimcp…I successfully installed Node.js (0.12.5), dfu-util (0.8), Zadig (2.1.2), and the libusK (v3.0.7.0) driver. “dfu-util” can’t find the Core; obviously, “particle” can’t either. I get the exact same (identical) error message as @Raviteja.
Steps taken:
1: Install Node.js, then install Particle CLI (painless)
2: Locate, download and unzip dfu-util, add it’s location to the system PATH variable
3: Put the Core in DFU mode (blinking yellow), run Zadig, install the libusK driver (piece of cake)
4: Restart the Core (just in case), back to DFU mode, run a command prompt, run “dfu-util -l”…and it doesn’t list any devices.

BINGO–just before I was another problem, I found the solution. You cannot connect the core to a USB 3.0 controller for dfu-util. My computer conveniently has two USB 3.0 ports on the front, and dfu-util can’t find it there. I plugged it into a port on the back of my computer (alas, the Particle cable is a little too short for me to reach it!), and dfu-util immediately listed two devices. (Also noted on Windows 7 + dfu-util + USB 3)

—EDIT—found another link saying that CLI won’t work on USB 3.0 ports, so cleaned up my post, and added link to the other post.


Weird as all Mac OSx ports are USB 3.0 and i never had issues.

It could have to do with how the platform (Windows vs OSx) handles USB ports. (Warning: this is unverified speculation. . .don’t write a book based on this post :grin:) It’s very possible that OSx classes all USB ports under the same class, and Windows uses a different class for USB 3.0 ports. If this is the case, the DFU-util program is probably enumerating the USB ports of a specific class, neatly excluding the USB3.0 ports from the search on Windows. (And of course, it can’t find a device plugged into a USB 3.0 port on Windows.)

For “proof” of the above speculation, I will note that without a driver, the USB 3.0 ports on my computer didn’t work at all. No USB 1.1 compatibility mode–no, nothing, nada, zilch. In addition, USB serial from the Core works perfectly on the USB 3.0 ports on my computer: it’s just DFU-util that doesn’t work.

Thank you for the article. I’m experiencing connectivity issues and the blinking green. I am able to flash --factory tinker and --usb tinker successfully but when I flash --usb cc3000 I get the following error:

Sara$ particle flash --usb cc3000
Found DFU device 2b04:d006
Error writing firmware...no known App found.

Any idea what I can try next? I got my Internet Button last week, had lots of problems, couldn’t get it working and shelved it for a week. Got it working this morning, played SIMON on it all day, put it away before my husband came home to find me slacking… and now that I have taken it out to show him - it isn’t connecting no matter what I do.

It seems as though cc3000 was not part of the package I downloaded. Ideas anyone?

I’ve verified that I do have the cc3000 update binaries in /usr/local/lib/node_modules/particle-cli/binaries/ as well as a new copy that I have placed in the directory I am working out of… Still no dice.

You have a photon and it is using a BCM43362 Wifi module so cc3000 patch doesn’t apply.

Can you tell me what is wrong with your Photon?

I moved 2 posts to a new topic: Photon blinking green

:frowning: I was able to connect the Spark to my wifi access point and claim it only once (and only after I rebooted the AP itself). After that i’ve never been able to go past the green blinking.
I’ve tried to patch the CC3000 but i get the error message

Cannot open DFU device 0a5c:21e2
Error writing firmware…Cannot open DFU device 0a5c:21e2

My device is a Spark and is set in DFU mode connected to a USB 2.0 port. libusK driver installer via Zadig. I’m running Windows 10.
dfu-utl -l shows this

dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Deducing device DFU version from functional descriptor length
Cannot open DFU device 0a5c:21e2
Found DFU: [1d50:607f] ver=0200, devnum=33, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg", serial="6D72246C4852"
Found DFU: [1d50:607f] ver=0200, devnum=33, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg", serial="6D72246C4852"

hmmm… Can you do the following:

Ok, i’ve tried the steps on another machine (Windows 8.1 and only USB 2.0) and i’ve managed to flash the board.
Now it seems to be connected, hope it will keep working :smile:
Thanks @kennethlimcp for your help.

I’m having the same blinking green problem, after having successfully connected my (original kickstarter) core ONCE. I’m on a Win10 system, and there’s a hint in the last few posts that this may be a problem. I will follow the advice given and see if it helps. One copy-edit point: the recipe for fixing “very old” spark cores has a repeat (lines 3 & 4), which temporarily confused this particular naive user when he tried “next particle --usb tinker” after doing a successful “particle --usb tinker” in the previous step.

The CC3000-patch did not fix my problem (although, unlike the previous poster, I am still running on a Win-10 system, with USB 2.0 ports, I might add). I’ve re-flashed everything I’ve been told about, and reloaded Tinker countless times, but no luck. Interestingly I have a Photon that I bought (along with an Electron, which is soon to arrive), and it works just perfectly. Different radio, different results. Happy to try out any other suggestions!

The OS you are using has no effect on the patching of the Core.

You might want to verify that the network is compatible with what the core might require.

CC3000 patch suggestion fixed my issues here after patching I invoked particle setup again and did the network registration over usb particle serial usb, thnx and cheers! I run ubuntu 14.4.

1 Like

Is there any way to fix it if I can’t connect it to USB? I have a v1.0 Core and the USB port broke off some time ago. Now it just flashes green, even after factory reset with the buttons.

Sadly, you need the USB port to put it in DFU mode… Unless you have a STLinkV2 or programmer shield around.

I do not… that’s unfortunate. Thanks!