Spark core cannot flash when many people connected to the WiFi


I’m at Hacker School, and we’re working on a project trying to hook up the Spark Core to a remote control car. We’ve had all kinds of issues flashing the Core, even had trouble claiming it over the Wifi at first, though after manually uploading the credentials via serial, it connects to the network fine. We did also try claiming and flashing the Core over a temporary phone-tethered wifi setup, and that worked perfectly.

There is a heavy-duty wifi network here, with upwards of 60 people connected at a time and an appropriately fancy router. We tried updating the firmware on the Spark Core, etc., and it solved the cyan flash of death issue, but we still continue to have problems connected and flashing over the wifi.

When we try to flash it, it does start to flash magenta, but then it does one of the following:

  1. the light simply dies, and then eventually the Core restarts and goes through the blinking green > blinking cyan > breathing cyan cycle, unflashed
  2. it continues blinking magenta forever and we have to unplug and replug it
  3. it goes into cyan flash of death [this particular issue was solved by a firmware update]

While working late at night, we did notice that when fewer people were around, the Spark Core did flash successfully, multiple times–so we suspect that having too many people on the network may be the culprit. Has anyone else encountered this or know how we can address it?

The underlying cyan flash of death issue is still there, but the Core does a pretty good job of mitigating it. However, a busy network will definitely exacerbate the problem with the added traffic and cause problems like you are experiencing since the underlying CFOD issue hasn’t quite been addressed by TI. However, it looks like @mohit is testing the latest patch from TI as we type.


One other thing to consider, unless more work has been done on this since my last post on the topic, any interaction with the sflash, including the stock firmware’s OTA update will be flakey at best using the new cc3000 driver. My previous post on the topic was here:

1 Like

We’re getting close! You can find the thread for that bug here: :slight_smile:


I have this exact same issue. I have flashed various codes today, but it goes through maybe 1 out of 20 times. Needless to say this is very frustrating. I can connect and flash reliably at home on a quiet network, but at work, with a lot of people connected to wifi, (fancy router) it’s almost impossible. It does get better at night when other people go home.

Do I have to do anything special to make sure I have the latest firmware, or just flash any code to my core over the air will do it?

It’s also worth noting that, at home, the apparent frequency of the magenta blinking led during flashing is quite a bit slower than at work.


Hi @davep,

Right now the over the air firmware update is what I call a “latency bound” operation, so as the latency of your connection increases, it significantly increases the delay for an update. We’re testing a non-latency bound version and hope to have it out in the next few weeks.

We’re still waiting on the approved official patch from TI (last I heard), but we plan on rolling that out next sprint.