[SOLVED] Why does particle-cli not run on fresh Ubuntu 16.04?


#1

I just created a new Ubuntu 16.04.5 i386 VM, but it will not run. This is after running the standard install script

bash <( curl -sL https://particle.io/install-cli )

I had to sudo apt-get install python to get this far, but the ~/bin/particle program just does this.

Edit: Network connectivity is a touch sluggish from the VM, but it is definitely connected to the internet.


#2

I installed this distro in a VM solely to do this job. What should I be using? What was this intended to run on?


#3

Looks like its having some difficulty fetching Node. Not sure why that is.

Have you tried installing Node (or NVM)? I’m wondering installing it independently may resolve it if you have not already.


#4

I began the manual install instructions after the standard way borked out. Installed and updated npm, had to install nodejs-legacy to get node to work, but it apparently installs in strict mode and doesn’t like the way whatever happens when you run sudo npm install -g particle-cli.

Dead-ended there and decided I didn’t have a zillion hours to fix it, thus this post.

Honestly I think I ended up fixing this the last time by giving up and installing po-util too. It’s already done. I hope you guys pay @nrobinson2000 well.