[SOLVED] Switching wifi networks: FAIL!

My Photon worked like a charm, then I wanted to use it with another wifi network.

I erased wifi credentials, unclaimed my device, reflashed the official firmware, then tried to setup the new AP with particle serial wifi which searched for access points forever.

The Android app showed the following couple relevant screens when trying the setup the Photon:

After the verifying product ownership step I get:

I’ve done the above several times, tried pretty much everything and wasted a couple of hours. This is the poorest user experience ever, and I can’t believe Particle can’t do better.

Any ideas of how to unbrick my Photon?

Unclaiming is not necessary but even counter productive for your intent.
Neither do you need to flash other firmware.

Just have your device in Listening Mode (blinking blue) and, using the CLI, use

particle serial wifi

then opt for not-searching networks but provide the credentials manually.
After that hit reset.

Thank you very much for the quick reply! It seems to me that the problem was that I provided an invalid wifi password. Unfortunately, based on the error messages this was not apparent at all.