[SOLVED]Photon does not create access point

Got 3 more photons today, 2 of them went trough the setup flawlessly, but the 3rd one is flashing blue but not creating a wifi network, so it does not appear in the mobile app.

Tried running particle setup over USB, but it seems to rely on getting on the same wifi also ?

Whats the correct workaround to use here ?

If you’ve got the CLI working, try particle serial wifi that should let you manually enter credentials over serial. Mind you that you’d still have to claim it then. particle identify along with Particle device add [ID] should help with that.
Let me know if that worked for you.

Hmm, serial didnt work, timeout.

C:\Users\MORA>particle serial wifi
? Should I scan for nearby Wi-Fi networks? No
? SSID: G82
? Security Type: WPA2
? Wi-Fi Password: passwordhere
! Something went wrong: Serial timed out

Could you place it in DFU mode and do particle update after making sure you’re on the latest CLI? That should update the system firmware, and might also fix some of the issues you’re currently facing.

Hmm, I havent had luck getting dfu to work yet.

I downloaded the windows drivers, and updated the photon in dfu mode to photon.cat but it just fails with “Device cant start”.

Have you tried following this tutorial, it has worked nicely for me in the past to get DFU working :smile:

1 Like

Thanks :slight_smile:

The zanig program fixed the dfu driver, and allowed me to update it using cli.
After running particle update I could claim it with the mobile app.

Was this because it was shipped with a old firmware, so it will be less likely to happen in the future ?

Glad you got it working :smile:

Not sure if it’s related to the older firmware, but the new one does have some fixes in regards to stability, connection-wise as well. That’s the reason the automatic firmware updates are now available, as to enable pretty much anyone to conveniently update to a more recent version.