[SOLVED]P1 module keep blinking green but was working few days ago?


I got two P1 board and it was working few days ago. Now its keep blinking green and my network works. Did something update or change recently? It was working great before. I try reclaiming but still keep blinking green…

Found the problem, work network is to weak or not working even tho it work on my iphone. Tested with my home wifi, the module connected. LOL need to ask boss to upgrade network.

iPhone might not be an appropriate test device, since it’s 5GHz enabled and the Particle devices are 2.4GHz only.

@ScruffR, unfortunately I am using and Iphone 4s which only have 2.4GHz as far as I know. I am still having the same problem at work, my Iphone can connect to the network but the P1 can’t. Below is the log:

016-11-23 09:47:20.994 TW[1318:430922] DeviceID sent
2016-11-23 09:47:24.022 TW[1318:430922] Could not send device-id command: Timeout occured while waiting for response from socket
2016-11-23 09:47:27.077 TW[1318:430922] DeviceID sent
2016-11-23 09:47:27.093 TW[1318:430922] DeviceID response received: 1e003f001747343432313031
2016-11-23 09:47:27.095 TW[1318:430922] PublicKey sent
2016-11-23 09:47:27.254 TW[1318:430922] PublicKey response received
2016-11-23 09:47:27.254 TW[1318:430922] ScanAP sent
2016-11-23 09:47:29.663 TW[1318:430922] ScanAP response received
2016-11-23 09:47:39.501 TW[1318:430922] sparkSelectNetworkVC prepareForSegue : require_password
2016-11-23 09:47:40.191 TW[1318:430922] Unbalanced calls to begin/end appearance transitions for <SparkSelectNetworkViewController: 0x16a07210>.
2016-11-23 09:47:59.930 TW[1318:430922] configureAP sent
2016-11-23 09:48:03.357 TW[1318:430922] Error sending public-key command to target: The operation couldn’t be completed. Socket is not connected
2016-11-23 09:48:03.358 TW[1318:430922] configureAP sent
2016-11-23 09:48:03.359 TW[1318:430922] Could not send device-id command: The operation couldn’t be completed. Socket is not connected
2016-11-23 09:48:03.374 TW[1318:430922] Could not send scan-ap command: The operation couldn’t be completed. Socket is not connected

I am using particle connection flow. It seem like the Socket is not connecting. Is this the network?

Solved, make sure to check network router first when see blinking green if everything else works.

1 Like