[Solved] Build didn't produce binary Error: Command failed: /sp

The topic is the exact error message I am getting in Spark Dev. I updated to the latest version of dev and cli because my Photon needed a kick in the backside. Any idea what is causing this or how to see the rest of the error message? When I click on it, it pops down the compiler message but says no errors…

That error pushed me to go back to using the Build web Dev.

Have you tried the classic exit Patticle Dev and restarting?

Yup…and a reboot. I opened the developer console and I have a ton of references to missing files.

file:///C:/Program%20Files%20(x86)/Particle%20Dev/resources/app.asar/static/token-iterator.js.map Failed to load resource: net::ERR_FILE_NOT_FOUND

I did a bunch of stuff but it was ultimately because I had a printf command in my sketch.

I found it by using particle compile photon c:\mysketch

I have submitted this bug, you can see the full error message for now by going into the view source like you would any webpage