RMA process - is it effective

What is the RMA process?

Has anyone had a good/bad experience with RMAing Photon units that don’t behave as expected?
I’m interested in hearing from users who have had issues with their Photon devices and ended up RMA-ing them.

@corey can take this.

My own personal, unbiased experience: In the early, early days of Spark (January 2014, months before elites even existed), I had a misbehaving Core that didn’t work for some reason or another. I had a brief exchange with someone hello@particle.io * to try a few troubleshooting steps and finally declared it as dead. From the time we began diagnosing the issue to me receiving a replacement was 10 days (total, not 10 business days).

If you do have a Photon that needs to be RMA’ed, check with @corey here on the forums and/or send an e-mail to hello@particle.io and reference this forum thread. If you can, try working with support to try and diagnose the problem. It’s possible that it’s fixable without having to ship things across the country (or around the world).

* it was actually spark.io, but I wanted to post the new address in case anyone stumbles upon it.


it depends on the clarifying statement of “don’t behave as expected”.
If you’re referring to a defective unit in terms of a mechanical error/failure or a bug that is deeply embedded in the system firmware not being flashed properly, then RMA is warranted. Mostly handled on a case by case basis, with a simple set of steps to verify “dead on arrival” vs user error.

thanks @kennethlimcp and @wgbartley for tagging me


Hi Corey I have 2 units (out of 4) that are “mis-behaving”:

Unit 1: upon powerup immediately begins to blink blue (on the multi-color LED) - does not transition through the usual bootup processes. Pressing the reset button has no effect whatsoever. Pressing the Mode button stops the blue light blinking and when pressed and then immediately starts it blinking upon release. All this time the D7 (IIRC) LED is lit very, very faintly. This is very unusual and unexpected behavior and I feel this unit is simply defective or that the firmware image is corrupted and I have no way to reloading it (without a JTAG programmer). I’d like to RMA it.

Unit 2: Seems to follow the usual bootup behavior. The reset and mode buttons function as expected. The unit appears on the Android app - but clicking on the identified device (on the android app) causes the screen to go blank - does nothing for 20 or so Seconds, and then returns to the screen that identifies the devide. I’ve tried the particle cli app - I’ve tried everything that I can think of and spent over 8 hours trying to resolve this issue - all to no avail. My conclusion is that the board is mis-behaving. I’m not willing to put any more time into it - I’d like to RMA it and have you look at it and tell me if I missed something.

Let me know how to proceed.

Al Hopper - you have my email address.