Refusing to connect at all Netgear D6300

OK trying to connect My core to a Netgear d6300.

Yes it is backward compatable
Yes I have checked the router user and password
It goes through the LED colour cycles as per the web site, starts breathing in Cyan
The App on my phone comes up No Core found… Determine i have the lastest version of the phone app.
Whilst the core continues to indicate all good (breathing Cyan)

I have connected previously but with a different modem type.

No luck connecting to USB either.

Followed all instructions to the letter. Am running win7

Not sure what to do next, tried 2 different cores, with no luck…

I do note on the router it is detecting the device, and at times a strange ip address 169.254.0.55 appears in the attached device listing.

Is there a way to determine the Cores Mac address to see if it is attempting to connect or what it may tell the router its device name. I can see an extra device in the attached devices but not sure if it is the spark.

Regardlees, the android phone app says no Core found. I have tried again resetting the core using mode, for 10 secs

OK on monitoring the attached devices on the wirelss modem i can detect that the core is attaching it is just not getting captured…

Note that i get devices connecting only after i have used the WPS button on my modem. AFter i do this during the connection process i get two devices connecting…

1 192.168.0.9 ANDROID-2C1EEB9632E2F9C7 38:AA:3C:FD:EA:6B
2 192.168.0.11 – 08:00:28:56:F6:71

Before this happens I get a device with a strange Ip 169.254.0.55

ok at wits end apologies for the convoluted explanation, I do hope it is sufficient to arrive at a conclusion.

Could it be that i have not attempted to attach the cores for quite some time?

What’s the led status on the core when you attempt to connect using the App? It should change from flashing blue to flashing green.

If that happens then the core did managed to talk to the router and maybe some router settings is causing the problem.

I’ll post my core mac address in a but for you to compare and find a similar one in your device list :slight_smile:

Opps. I realized you mentioned that the core is breathing cyan.

Are you able to program through the spark cloud? If that’s working then the problem is isloated to just the android app, router and spark core :slight_smile:

My Mac is 0800285780082 as shown on my router. Did a check online and it’s correct. Matches TI.

  1. Since your core can turn breathing cyan, it means you have previously setup with the Tinker app and got the wifi credentials in

  2. Are you able to see the core listed in your App? If yes, look under the menu and ‘Reflash tinker’

The core will start blinking magenta to download the tinker firmware. Once it’s completed, the core will restart and turn breathing cyan

  1. You should now set D7 to DigitalRead and toggle it. The led near the usb port should tinker :smile:

I just did it and it works!

Thanks for the response, appreciate that.

ok eventually was able to connect via USB (putty) Serial, after resetting all devices.

And was able to manually capture the device via the PC. WHoo hoo.

Did the reflash TInker, waited till breathing cyan…

set D7 to DigitalRead and recieving a "We have encountered an eroor. please visit www.spark.io

Status code 404

Should be digitalWrite since it’s an output to the led :slight_smile:

thanks, same issue…

tried th build app, code compiles, flash appears to work and no blinking LED’s…

Here is the code, and thank you by the way for your assistance.

// This #include statement was automatically added by the Spark IDE.
#include "lib1.h"

// We name pin D0 as led
int led1 = D0; 
int led2 = D1;
int led3 = D2;
// This routine runs only once upon reset
void setup() 
{
  // Initialize D0 pin as an output
 pinMode(led1, OUTPUT);
 pinMode(led2, OUTPUT);
 pinMode(led3, OUTPUT);
 }

// This routine loops forever 
void loop() 
{
  digitalWrite(led1, HIGH);   // Turn ON the LED
  delay(5000);
  digitalWrite(led2, HIGH);   // Turn ON the LED
  delay(5000);                  // Wait for 1000mS = 1 second
  digitalWrite(led3, HIGH);   // Turn ON the LED
  delay(5000); 
  digitalWrite(led1, LOW);    // Turn OFF the LED
  delay(1000); 
   digitalWrite(led2, LOW);    // Turn OFF the LED
  delay(1000);
   digitalWrite(led3, LOW);    // Turn OFF the LED
  delay(1000);  // Wait for 1 second
}

Hi @setsuzoh; there is a known issue where long delays (<10s total) will cause the Core to silently disconnect from the Cloud, because it cannot complete its heartbeat. If you re-write your code to be non-blocking (by comparing the time to millis(), as an example), it should function just fine.