Recover from CLI command "particle keys server"


I’m troubleshooting my Argon and tried the CLI command “particle keys server”. After that I unclaimed my device in order to redo the setup via mobile.

Setting up via mobile now fails when connecting to the cloud.
How can I fix this? Im thinking it is related to the command.


Mesh devices use special cloud server instances, please try the following:

$ particle keys server --protocol udp --host '$'

I have also created an issue in particle-cli repo:


Thanks for your help avtolstoy. I ran the command:

particle keys server --protocol udp --host '$'
particle-cli v1.35.2

! A newer version (1.36.0) of particle-cli is available.
! Upgrade now by running: npm install -g particle-cli

Okay!  New keys in place, your device will not restart.

After that I tried setup via mobile again. It still results in an Error: "Your deive could not connect to the device cloud. Please try again.

Additionally, if not in setup mode (blinking blue) or dfu mode (blinking yellow), my device is blinking cyan (fast) and occasionally orange, which would indicate a decryption error according to

I also tried the following, but device is still blinking cyan and orange:

particle keys doctor <id> -v
New Key Created!
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Opening DFU capable USB device...
ID 2b04:d00c
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCD Flash   "
Downloading to address = 0x00000c22, size = 121
Download        [=========================] 100%          121 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
attempting to add a new public key for device <id>
submitting public key succeeded!
Okay!  New keys in place, your device should restart.

Okay, so they updated the docs:

1 orange blink: Decryption error.
2 orange blinks: Could not reach the internet.
3 orange blinks: Connected to the internet, but could not reach the Particle Device Cloud. This sometimes is seen as yellow or red and indicates bad server keys.

I count 3 orange blinks in my case, which would still indicate bad server keys. Any idea how to fix this?

Have you redacted <id> to hide your actual device ID or did you actually write the command that way?
Also there is now CLI v1.36.3

Yes, I changed it with my actual device ID which I obtained with particle identify. Wasn’t sure if it was sensitive data so I let it out here.
I updated to 1.36.3 since my post from last week. Tried the commands again without success.