Problems powering the core with a voltage regulator


I have now spent quite some time trying to figure out where this is going wrong, so I though I’d ask you smart people before I burn another core.

I have the following setup, where I am trying to power my core from a 15V DC source. The problem is that when I measure the voltage between Vin and ground on my core, it is 5V DC and 10V AC and I am at a loss as to why. The problem only occurs with the core as far a I can see, but as I have tried with another core too (the one that burned), I don’t think it is the problem. I have also tried with several different L7805 for IC1, all with the same result. Has anyone else had the same problem?

IC1= L7805CV, C1=330nF, C2=100nF

Simply measure the Output side of the regulator and make sure you have 5V before connecting to the core.

You should probably check if your 15V supply is AC or DC! Do you have access to an oscilloscope to look at the power waveform?

Thank you for the fast replies =)

@bko My power supply is rectified before going to the voltage regulator, sorry for omitting that from the drawing. I have measured the voltage after the rectifier; 15V DC, no AC at all.

@kennethlimcp I have measured the output of the voltage regulator and all five that I have gave 5V DC and 10V AC. Apparently it has nothing to do with the core… I thought voltage regulators were simple things, plug-and-play so to say. I find this very strange since the setup with the condensators is straight from the datasheet of the L7805. The condensators by the way have no effect at all, I have the same measurements without them.

When you say you have 10Vac, how are you measuring this?

If you are using a mult-meter and measure on the DC setting, 5V then the supply is working.

I have a multimeter that when measuring DC gives 5V and when measuring AC 10V on the output of the regulator. On the input of the regulator I have 15V DC and 0V AC. If this is expected, then what should I use instead? Do I need to use a diode on the output? I have one burnt plastic smelling core that says my current setup is not working, so something is wrong =)

When you say rectified, what exactly do you mean?
Is it just a one diode or a bridge rectifyer? Is it filtered, or not?
If it’s not filtered, I’d suggest to do so. The 330nF will not be enough to smoothen the pulsating DC.

1 Like

It sounds like your 7805 is oscillating.

This is usually caused by lack of decoupling capacitors and/or long wires adding inductance.

I am used to using far larger capacitors (e.g. 47uF on input, 10uF on output) in addition to some small value (100nF) caps on both input and output - as well as keeping the length of flying leads as short as practical.


I’m powering a core from a 12V DC solar system. I used a 78E5.0-0.5 switching regulator to get 5V from the 12V solar battery. Decouplers both sides of the regulator are 0.22uF. Works just fine. Draws 70mA from 12V when the core is awake and 20mA when asleep.

When you have a solar panel or a battery you can have capacitors with less capacitance - you have propper, clean DC already.
But if you have an unfiltered, rectified DC coming from an AC source, you have to have bigger ones.

1 Like

To not leave this thread dangling: I finally had time to try with some more capacitors today, and it seems @AndyW was right about the oscillation.

I now have a main condensator of 1000uF directly between plus and minus, a 47uF and a 10nF on the Vin and a 22uF and a 10nF on the Vout of the regulator, giving me exactly the 5v DC and no AC that I wanted.

Thank you all =)


Glad to hear you got it working.