Photon will connect to wifi, but isn't recognized

I own a photon redboard from Sparkfun Electronics, and it has the same specs as a regular Photon. When I tried to find it with my android app, it wouldn’t find it so I went to use the command prompt route. I installed all the needed drivers, and when I connected my Photon to the Internet, there were no errors. But then I tried to find my particle 24 bit id, I would get !serial Serial timed out. I reset my Photon and my Computer, but I still ran into the problem. I used “particle list” to try and fin the device, but it said no devices were listed! I decided then to factory reset the device and then use the particle auto setup system, but when it tried to search for the photon, it couldn’t find it either although I had directly connected to my computer!

My internet network has WPA2 security and I installed the 64bit node.js and particle drives.

Is my photon redboard broken, or am I doing something wrong?
I would love to know.

Interesting, considering there is no factory reset…

Regardless, while making those calls, was your device in listening mode (blinking blue, assuming there’s a status LED on the Redboard)?

Yes it was in listening mode. I didn’t know there wasn’t a factory reset, but i read that if you want to fully reset the Photon you should hold the Mode button for three seconds.

If you want to see what the photon redboard is: https://www.sparkfun.com/products/13321

And here’s the setup guide if you need it: https://learn.sparkfun.com/tutorials/photon-redboard-hookup-guide

Can you post a link to that statement? It might need correcting then.

What OS are you using?
If Windows, can you see the device in Device Manager? (screenshot?)
Do you see the device when in DFU Mode in DevMgr? (screenshot?)
Have you tried different USB cable and port?
Is your WiFi a 2.4GHz network (not 5GHz!)?

particle list won’t show you the device before you were ably to claim it.