Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

so here I am having this same issue; and I tried this:

and that didn’t help, so I did this:

and I still get the cyan flashing with brief periods of red, like @avidan, the OP

not my day I guess!


for the record, @kennethlimcp helped me solve my problem via a PM.

I wanted to give @kennethlimcp props for being so helpful to this forum, and to me personally, so BIG THANKS @kennethlimcp!!!


Would you mind sharing the solution in case others hit the same problem?

Right, yes!

reset the device keys (as above)
reset the public key (as above)

and finally…


Can you do a particle keys send deviceid

We might really have to wait for Mat to give directions on this.

1 Like

In summary:

  • particle keys server cloud_public.der
  • particle keys new photon
  • particle keys load photon.der
  • particle keys send

Ok, so this was on a Photon that was already claimed?

I’m curious to know what made the installed keys go bad?

That I cannot answer except that I attempted to add the Photon to a new wireless network, after I claimed it (out of the box) on another WiFi network.

I went through WiFi setup and it never made it past flashing cyan.

I have tried connecting my Photon through 1) Particle CLI setup and 2) Particle iOS setup.

Each has resulted in flashing cyan lights with a red flicker occasionally.

Can someone help troubleshoot so I can get this Photon connected?

Particle CLI Experience:

$ particle setup

Setup is easy! Let’s get started…
It appears as though you are already logged in as MYEMAILACCOUNT
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You may lose your connection to the internet for a moment.

? Found “Photon-XXXX”. Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

Hey! We successfully connected to Photon-XXXX

Now to configure our precious Photon-XXXX

! PROTIP: I can only scan for Wi-Fi networks that broadcast their network name (most networks do).
! PROTIP: If you want to skip scanning, or your network is configured as a non-broadcast network
! PROTIP: answer yes to the prompt below. Otherwise, we will continue with the Wi-Fi wizard setup process…

Would you like to manually enter your Wi-Fi network configuration? No
Please select the network to which your Photon should connect: xxx
Please enter your network password (or leave blank for none): xxx
Here’s what we’re going to send to the Photon:

Wi-Fi Network: XXX
Password: XXX
Security: XXX

? Would you like to continue with the information shown above? Yes

Obtaining device information…

Obtaining device information…

Obtaining device information…
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…

Configuration complete! You’ve just won the internet!
Would you like to return this computer to the wireless network you just configured? Yesnfigured? (Y/n) Y
Fantastic! You should be back to normal now!

! PROTIP: Your Photon may start a firmware update immediately upon connecting for the first time.
! PROTIP: If it starts an update, you will see it flash MAGENTA until the update has completed.

Ok, bye! Don’t forget particle help if you’re stuck! <3

$ particle list

No devices found.

$ particle device add DEVICE_ID

Claiming device DEVICE_ID
Failed to claim device, server said { ok: false, errors: [ ‘Device is not connected’ ] }

$ particle identify

! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)

Particle iOS Experience:

Login to Applcation
Your devices
Setup a Photon…
Find Photon Listed in Network
After selecting Photon newrok, push notification returns to App
When I return to the app, I get a prompt saying:
Product ownership
This Particle device is owned by another user, do you wish to change ownership to EMAIL_ADDRESS?
Select Yes
Select wifi network
enter password
Setup failed
Setup process failed at claiming you Particle device.

RESOLVED: device keys and cloud settings got messed up. once this was fixed photon back online and connected

@Ashton, if you don’t mind, can you tell me how you fixed the keys issues? So that i have some idea of what users are doing when things fail.

Thanks! :wink:

Just wanted to let everyone know that apparently keys can get corrupted at brown outs. I tried running
my Photon directly off a 10W USB solar charger that is one of the simple ones where it outputs voltage even if it doesn’t get 5V. It reset a few times and I wanted to see whether it would boot once the sun is out from the clouds. After that it first
only flashed blue, then I set up the WiFi and it flashed cyan with intermittent red. Reflashed the 0.4.3 firmware but that
didn’t help. Then I regenerated the key and sent it to the cloud and that finally did the trick.


Could you help why I get this error?

C:\Users\Amir\Downloads>dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Cannot claim interface

Are you using a USB3.0 port?

I use a USB2 port.

I suddenly tonight am having this issue with three Photons that had previously connected to the cloud and were previously working fine… I normally have them operating in SEMI_AUTOMATIC mode (connecting to Wi-Fi but not the cloud), but went to connect one of them to the cloud to re-flash. Instead of connecting successfully like normal it flickered cyan with red bursts. I thought something must have happened to this Photon so I tried one of my other ones, and it did the same thing! Then another! All in the same night… I have a big meeting tomorrow so this is horrible timing, and I can’t seem to get dfu-util to work to try new keys, I keep getting “No DFU capable USB device available” even though I have installed the drivers with Zadig and have the Photon in DFU mode. Any ideas how I can fix this with my Photons ASAP!??

I was able to update the keys and get rid of the red bursts by switching to a Mac (instead of my Windows machine) which was able to recognize the Photon in DFU mode, then following the steps provided by @mdma here. But what the heck could have caused this?

This often doesn’t help ;):

There are so many odd quirks in Windows that can seriously mess up pretty much anything, itself included. Try uninstalling all the particle drivers, and installing them again. That might help. Using different USB ports/cables can also make a difference.
As to what may have causes the red bursts, not really sure…

Wow that’s terrible luck to have all 3 fail, sorry for that. If you’re able to reproduce the problem I’d love to know how so we can investigate.

If it happens again, please make a dump of the memory using this command (with the device in DFU mode), and send me the resulting file:

dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U dump.bin



I have the exact same problem and have tried everything in this thread. I have made a dump of the memory, where should I send it?


Thanks @mdma, if I encounter the issue again I will try to note the specific steps leading to it. I’ll also save the memory dump file and send it your way! One strange thing to note from what happened to me Monday night is that the third Photon I tried wasn’t even running the same firmware as the other two when I connected it to the cloud and saw the cyan flashing with red bursts.

1 Like

I have recently experienced the same problem as described in this thread. After ‘reseting’ the keys, my Photon is recognized as ‘online’ in the developer Dashboard, but it is not properly recognized in the Android App or the Web IDE.

I started experiencing this problem with all of my devices: 2x Photons and 1x Core. (although, I don’t spend much time troubleshooting the Core)

!!! Exclamation points!

I put my Photon in my project after it was working flawlessly and I got these gem. Been at this for hours trying to cobble together sending the key to the cloud. (Installed CLI, then DFU was down…, factory reset, then the Photon refused to show up under the USB utility, then again, then dfu was in the wrong directory, then all the base belong to cloud…)

I have been having the same problem as the above post before this happened and it did it with every single device. Every single one showed up, but would not Tinker or Build flash…

I am stuck trying to dump my key right now, it looks like it isn’t liking openSSL. I grabbed the utility and followed the thread on installing all the goodies… Is there some way to manually run the command that is failing?