Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

Did on my clean machines tho’

I haven’t had any luck with any of the suggested options.
I’m still getting the quick flashing cyan with the quick orange burst. I’ve tried everything from setting it up on my phone to setting it up on my computer. I tried upgrading the device firmware with particle upgrade and then manually using the github repository and documented upgrade path. It seems like I can do almost everything via my phone except for claiming the actual device. Then, because claiming the device fails, everything else seems to fail as well. This all came sort of out of the blue.
The only thing I can think of was that one of my software firmware pushes had some of the wifi options included (disconnecting from wifi and scanning for a specific one) Could it still have retained the wifi.disconnect() command somewhere deep in the firmware even though I’ve reset it multiple times. Flashed tinker, updated keys, used the particle doctor. Also, my router has the 5Ghz capability, but the SSID for that one is different, so I’m only connecting to the 2.4Ghz. Someone suggested that it might have to do with a firewall on the router… anyone have any experience with that?
I’m kind of at my wits end with it.

You won’t need WiFi connection to run these commands in DFU mode and when you execute these commands, don’t just say you did, but post the output.

Isn’t it particle update? What was the output of that and what did particle identify tell you after it?


You’re right, it is particle update.
I found the trick though, even though I swear I’ve run the particle doctor like 10 times (because running the doctor on just the keys was not doing the trick.
I went through the full particle doctor command and subsequent prompts and finally had luck!
It turns out that the piece that was bricking my device wasn’t really bricking it, and it was the fact that I was missing SYSTEM_MODE(SEMI_AUTOMATIC); (my photon is running connected just to a local LAN)
Otherwise your photon will just try to endlessly connect to the cloud, essentially stuck in Particle.connect();


That explains everything :wink:

ps, frustrating that the particle cloud keeps bricking keys for client devices. Which requires them to mail them to us to fix up for them. Just had to fix another.

Hmm… Does the device sleep most of the time or always online?

I’ve suddenly started getting this issue on a system that’s been working properly for several weeks and that does not connect in any way to the Particle cloud. (i.e. “SYSTEM_MODE(MANUAL);”).

It started when I made a very small formatting change to the serial debug output and re-flashed. It now fast-blinks green, then fast-blinks cyan with an occasional orange double blink.

I tried flashing an empty project back onto the device and I get the same - blinking cyan with orange flashes.

I’ve tried running the device doctor. The first two steps succeed, but then I get a failure message when it attempts to set the Internal antenna. Here’s the output:

Stevens-Mac-mini:projects ssokol$ particle device doctor
The Device Doctor will put your device back into a healthy state
It will:
  - Upgrade system firmware
  - Flash the default Tinker app
  - Reset the device and server keys
  - Clear the Wi-Fi settings

The Doctor will operate on your Photon connected over USB
You'll be asked to put your device in DFU mode several times to reset different settings.

Updating system firmware

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

> Your device is ready for a system update.
> This process should take about 30 seconds. Here it goes!

! System firmware update successfully completed!

> Your device should now restart automatically.

Flashing the Device Doctor app

This app allows changing more settings on your device

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

Flash success!

Select antenna

? Select the antenna to use to connect to Wi-Fi Internal
The Doctor didn't complete sucesfully. undefined
> Please visit our community forums for help with this error:
Stevens-Mac-mini:projects ssokol$

Any ideas?

Looks like the firmware was compiled for 0.7.0. I flashed the latest bootloader:

particle flash --serial bootloader-0.7.0-photon.bin

and that seems to have fixed it.

More on this fix in this thread:

I’ve scanned through the above, but I can’t seem to even get my RedBear Duo to enter DFU mode. I’ve tried both my laptop usb and a power pack.

See the attached video:

I am definitely holding both, then release reset, then holding setup for over 30s…

Also in this state I can’t connect to it via the serial connection, and I am yet to claim it on the Particle cloud.

Am I missing something fundamental here?


(Apologies for the audio - yes it is “The Last Samurai” - Soundtrack Suite (Hans Zimmer))

You need to take the device out of that anti static sponge!
These spunges are slightly conductive and can cause some “short circuits” conditions that definetly interfere and possibly even damage your device.

1 Like

Ah thanks, novice error there

that seems to have done it actually. Took it out the damaging anti-static sponge and now its happy


1 Like

@ScruffR False positive, it went blue and allowed me to re-enter wifi details which I did, now back to the same issue with no DFU mode

Does the RGB pattern still look the same as in your video?
I haven’t a lot of experience with RedBear Duo but you can file a support ticket at

Meanwhile can you share another video.
With original Particle devices you could send the device into DFU Mode from Listening Mode via a setting a magic baudrate (14400) from the host - not sure if this is also possible on the Duo.

Here are two more videos showing the reset process again.

Ill have a look at the above suggestion @ScruffR

Could it be that the SETUP button is defective?

Potentially but luckily I bought two and they are both experiencing the same problem.

Unless I have two duds… I suppose I could have potentially short circuited the buttons on both of them given my earlier blunder

Apologies but this will be the least comprehensive resolution steps ever.

  1. Managed to get the things to reset and wipe wifi credentials by holding and the rest and setup buttons until blue light came back.
  2. In this state I checked thje firmware and both devices were on 0.3.1, whereas the latest firmware is 0.3.3

On to DFU mode…

  1. I had to unplug the device from my laptop USB. Using a power bank I had to hold both buttons down with a pair of wooden chopsticks then plug in the power bank.
  2. Releasing the reset button but not setup I found that I was able to get it into DFU mode… Finally…
  3. Once achieved on the power bank I switched back to the usb ports on my laptop and repeated the step 4…
  4. I checked the connection through the serial montior in the arduino IDE and used the IDE environment to run the burner which updated the firmware.

Now they both finally work and are connected to the Particle Cloud…

Going to go lie down for a bit ready for round 2 tomorrow

1 Like

Hey! I have been trying to troubleshoot this problem as well on my new Argon Board. I had it successfully connected but when I flash code to it, then I enter the fast cyan blinking with a red blink loop.

I have been going through this thread and tried several things, however, I always get stuck at this part:

C:\Users\Owner>particle keys server cloud_public.der
Please specify a server key in DER format.

And I am not sure what to do from here, I am hoping that once I do this part right, the Argon will be back and running correctly!