Photon pulses white constantly

I have opened the packet of my new Particle Photon. I have tried all possible solutions in the community forum but my photon pulses white constantly.

  1. I have put it in dfu mode and update it with “particle update” command, the result of this update is in screenshot below.

However, after the update, nothing has chagned. It pulses white again.

  1. Then, I have tried the dfu-util method in the link, result of this was the same.

  1. After all that, I have tried the method in the link. However, the result was the same.

After all that, I do not know how to solve this problem and run my Photon properly.

Are you able to put it in safe mode?

I’m not able to put it in safe mode.

  1. Hold down BOTH buttons
  2. Release only the RESET button, while holding down the SETUP button.
  3. Wait for the LED to start flashing magenta
  4. Release the SETUP button (At this stage, when I release the SETUP button, then it still pulses white)

I have uploaded a video in this link. It shows the problem that the Photon has.
Could you please help me with the problem ?

The photon is continually resetting for some reason.

Have you tried updating to the latest firmware?

Yes, I have updated to the the latest firmware.

Moreover, I have tried dfu-util method.

However, nothing has changed. The photon continuously pulses white.

Do you have access to a programmer shield?

What do you mean by “programmer shield” ? Sorry, I’m new to Particle Photon.

Let’s assume that’s a no :wink: I think the problem may be a corrupted DCT area. I will try to set aside time to make some custom firmware that resets the DCT region - this should get you out of the reset loop.


I will really appreciate your effort because I’m stuck in the current situation. I’m looking forward to receiving good news from you :smiley:

Thank you very much in advance for your help.

Here’s the steps to (hopefully) get out of this situation:

  1. download (the file has a .bin extension)

  2. install version 0.4.7 of firmware either via Particle CLI (particle update) or by manually flashing the files from the github releases.

  3. place the device in DFU mode and flash the file to your device

dfu-util -d 2b04:d006 -a 0 -s 0x8060000 -D reset-dct-part2.bin
  1. Reset the device. The device will display a solid green LED.

  2. Reflash system firmware 0.4.7

  3. Restart the device. The device will enter setup mode, since all wifi credentials are cleared. (This may not be the case if you have installed a custom application that doesn’t attempt to connect to WiFi.)

  4. Reflash the server public key - Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

That’s it! After these steps the device should be functioning normally.


After step 4, the device displays a solid green LED. After reflash system firmware 0.4.7, the device starts to blink white for 2-3 seconds, then starts to pulse white constantly. So, the problem is not solved yet. It behaves in the same way.

Ok. I will quickly flash the memory dump to my device tomorrow. If I can’t reproduce the problem then I think you may have a duff device. I will let you know.

I couldn’t reproduce the issue with the memory dump, so I can only conclude it must be a hardware problem. Our customer support team will assist you with getting a replacement.

I have same issue: SOS indication with hardware fault per document on modes

Except that I am using the P1 module and it is soldered to a PCB.