Photon dead after red flash and breathing green

###I (think) I accidentally destroyed one of my Photons today.

I was working on building a robot rover, and it was working fine, until the Photon started breathing green. I pressed the reset button to try to get it to breath cyan, but after I released the button, there was a red flash, it connected to Wi-Fi (flashing green), and then started breathing green again. I pressed the reset button again, and the same thing happened. I then pressed the reset button one more time, only for the light to not come on at all. I removed the Photon from its breadboard and tried powering it over USB. Nothing happened, except it started to get very warm. I then tried powering it from the VIN/GND pins from another Photon, to the VIN/GND pins on the broken Photon. No light. Powering to the 3v3/GND pin made no difference.

###What caused the Photon to die?
I don’t really know. I’m 99% certain that I didn’t accidentally short circuit it somehow, as it shouldn’t have been breathing green in the first place if it was “short circuiting”.

###Has anyone else experienced this?

EDIT:
The device ID was 1a002e000a47343432313031, if that helps anyone.

EDIT 2:
I just read the docs, and:

When the Photon is connected to a Wi-Fi network but not to the cloud, it will breathe green.

Weird…

I also read that:

There are a number of other red blink codes that may be expressed after the SOS blinks:

  1. Hard fault
  2. Non-maskable interrupt fault
  3. Memory Manager fault
  4. Bus fault
  5. Usage fault
  6. Invalid length
  7. Exit
  8. Out of heap memory
  9. SPI over-run
  10. Assertion failure
  11. Invalid case
  12. Pure virtual call
  13. Stack overflow

The Photon blinked red once before connecting to Wi-Fi and breathing green, but did not flash an SOS. Does that mean the Photon also “Hard Faulted”?

@nrobinson2000 while I can’t help you much on the issue that you are having on the Photon, I don’t recommend that you give out the device ID or access token.

Consider editing the post and removing the ID.

You can send it via PM to someone that you trust. i.e. @ScruffR or some of the others that normally contribute to this community. Also any of the Particle team.

Chuck

I didn’t give out my access token. Also the Photon is permanently destroyed, so I don’t see any problem posting the device ID.

@nrobinson2000 can it be placed in dfu mode?

Not at all. When I plug it in it just gets hot and the light does not come on. Dfu-util can not detect it.

I know that you didn’t give out your access token, when I first started with the Photon I did include my access token in a message, @ScruffR saw it and redacted it for me . I added that basically for the benefit of others.

@carbuthn, it’s not a stupid advice you’ve given and having done that once and having learnt from that isn’t either!

It’s true that a Device ID is not as sensitive info as an access token would be (even that can be posted if you deactivate it afterwards), but making a habit of not posting potentially sensible data at all prevents you from accidentally giving out too much information accidentally.

And a: “Thank you, but I was aware!”, would have been a more apropriate response than a snappy: “(I’m not stupid)”

2 Likes

Thanks, my initial message didn’t include the access token, I went back and looked at my messages and saw that my mistake was to include the access token. I then edited the message for general information to others.

1 Like

People can still go through the edit history of your post.

Device’s ID, Device’s ID, Device’s ID… @nrobinson2000 is right the unit is dead the Device’s ID doesn’t matter. "Photon started breathing green. " Welcome to the “Dead Photon Club”. I tried three more times with the same results. The odds aren’t in our favor to line the pockets of Particle.

Cheers

1 Like

I posted the Device ID, not the Access Token. An Access Token is actually bad to post, because posting would invite people to mess with my account and devices, but posting a Device’s ID (especially a broken one) is harmless.

Good point, I’ll correct it.

How many Photons have you lost to the “Green Breath of Death”? I’ve only lost this one.