Photon able to make to the Internet but not verifying

Particle team-

I’m have an issue with re-pairing my photon to my account. I power it and hold the mode button for three seconds until it blinks blue. Using the particle app on android I can see the device and it goes through all the steps and gets up to the “Verifying product ownership” and it gives me an error.

I also tried using the CLI and it said everything was good but when the it tried to check and see if my photon made it to the cloud is says I couldn’t find it.

The photon had worked in the past and the application was almost done. My application uses manual mode because I am only communicating to a Pi on the LAN. The app was working from boot up with a dedicated network and the Pi and after not touching (or so I think) it for a few days this issue happened where I could not recover. This is a two-fer:
1- how can I recover my photon
2- what was the potential cause and how can I not repeat it

-CB

If it’s breathing cyan, place it in listening mode, and issue particle identify then copy the device ID and insert that into particle device add [ID]. That should claim it to your account again.