Particle user programs list is missing

One of my Arduino students has lost access to his list of programs in the online Particle IDE. He had access to them yesterday, but when he logged in today the list has mysteriously disappeared (the example code projects are still listed). We are sure he is in the correct account because his board is still listed under devices. He found that by going into the browser’s history, it is possible to load his previous projects one by one (the directory of his projects is still unlisted). Does anyone have any idea of how to restore the list of his projects? Any help would be greatly apreciated!

PS will upload screenshots when I get back to the classroom

You could try clearing the cache in the IDE, or possibly trying a different browser?

Unfortunately clearing the cache didn’t help, and different browsers resulted in the same issue.

Here is a screenshot of the regular code screen he sees:

Here is an example of the code from one of the URLs copied from the browser’s history:


Pressing the save button does nothing to remedy the problem.

Could you check the console to see if that reports any errors? (right click -> “inspect this element”)

Yes! Here is a screenshot–

Hi @chessmaster2000,

This is almost always a case of being logged in under the wrong account, I’m not sure I’ve ever seen a project actually lost that wasn’t deleted intentionally, or just logged in under the wrong account. If you PM me that person’s username, I can look up possible misspellings.

Thanks!
David

Hey Dave! His is username is yepicness@gmail.com
Thanks so much!

That’s the correct email address for those projects, but I’m guessing he’s not logged in as that user. Have him log out, and log back in, typing his email address carefully and avoid auto-fill :slight_smile:

Thanks,
David

We have verified that this is what he is logged in as multiple times. The issue persists. We are able to connect and flash to the board from the programs in the URLs, but still not able to see the list of programs.

Hmm, maybe try a different browser? I definitely just tried logging in as that user, and saw projects.

Thanks!
David

We tried a different browser and the issue persisted. Further, this issue came up for another student (user kyle106@me.com) this afternoon and was also unsolvable. I’m glad you can see the list of apps-- hopefully this means we can resolve the issue both students are having.