Particle library create does not work in Windows

I’m having difficulty in creating a particle library. I was able to do this in the past, albeit it has been a while.

This is what I tried:

particle library create

And I get:

$ particle library create
A name parameter is required to create a storage

Form another post (sorry I cant find the link)
I tried:

particle library create --name testLibraryName

I get:

A name parameter is required to create a storage

My current configuration is:
Particle CLI version is 2.16.0
Computer: Windows 10, 64bit

What am I doing wrong?
TIA

I just tried almost the same command on Windows 10 and it worked:

particle library create --name testlib1

Make sure you’re running the command from an empty directory that will be the library source directory. The name of the directory should match the --name parameter. Also that directory and any directory above it should not contain spaces.

The -v option may also help provide better debugging.

You don’t actually need to use particle library create, however. All it does is create the examples, library.properties, LICENSE, README.md, and src directories in the current directory. You can just create them manually.

1 Like