Particle Electron not being recognized by computer

So the first time i set up the particle, everything worked well, it was recognized by the PC, i install the driver and connect to the network and was able to flash the LED blinking code unto it (from the web IDE). So after this, i tried flashing anther code on it and the particle disappeared from my device manager. I thought that was weird, so i unplugged it and plugged it back in, after a few mins, i get the breathing white LED… But the particle is no longer being registered by my PC (It doesnt see that anything is there, it is only giving it power). Even when i hold down the mode button, nothing happens, the LED doesn’t turn blue.

What i can do is hold down the mode button before i plug it in and that gets me into the DFU mode, or i can hold both the mode and reset and release one of them to get into listening mode (at this point it does come back up on device manager). Ive tried updating it and setting it up again, but as soon as i unplug and plug it back in normally, i get the same thing…Breathing LED, Particle not being registered by my PC (It doesnt come up in device manager).

Does it show up in Safe Mode?

That doesn’t sound like the normal behaviour. And I guess you only see that when you release RESET, releasing MODE while still holding RESET pressed should not show any activity.

Listening Mode (blinking blue) can’t be entered directly from reset, only Safe Mode (breathing magenta) or DFU Mode (blinking yellow) are accessible that way.

Yes, i can also get it into safe mode (this is what i meant before about holding Mode before plugging it in, not DFU).

When i plug it in normally, i just get the breathing white LED. The mode and reset button don’t do anything, separately, unless i hold them both down at the same time and release one.

That suggests that your code causes that behaviour.

To check, just put the device into Safe Mode and flash Tinker again.

Sorry, i am new to using this device and it’s environment and i don’t fully understand it yet. What is the role of Tinker ( is it the firmware for the device? ) and how do i flash it when it is in safe mode?

thanks,

Tinker is the original factory application firmware and a good known base for distinguishing between hardware and software issues.
You could flash any primitive sketch that has Serial.begin(115200); in setup()

If you have CLI installed, you can flash via

particle flash <yourDeviceName> tinker

or via Web IDE you can use the Tinker application code provided by Particle.

So i have the CLI installed so i can run the commands… My question is, when i run that command, doesn’t a file which contains the code for the firmware need to be placed somewhere? Or does the command grab the code for Tinker from an online repo?

Also, how can i figure out my device name?

Thank you.

Tinker will be grabbed from Particle.

Your device name will be displayed in Web IDE (target icon), or you can look it up via particle list

I tried flashing and it said
"flash device failed"
“timed out”

Then you can try flashing viaUSB in DFU Mode

particle flash --usb tinker

Thank you, this worked.

2 Likes

This topic was automatically closed after 2 days. New replies are no longer allowed.