Particle CLI Installer (Windows)


today running particle-cli on windows10 mentioned there is a newer version 1.17.0 available with npm install instruction. Install worked but running Particle from my working directory did not work. Kept running v1.16.0. Only when running from my \users\myself\appdata\roaming\npm directory it started v1.17.0. Why?
Actually I am not 100% sure. But swapping the last 2 items in the windows path variable solved it. So place …\roaming\npm BEFORE …\particle\bin. Now I can run Particle from any directory and get v1.17.0.


It could be that you’ve got two separate installations of the CLI installed, having only updated the manual one, rather than the installer version.


You might want tp use the global switch

npm install -g particle-cli


npm update -g particle-cli

npm update -g particle-cli

Does precisely nothing on my Windows 10 PC and install gives me this:

C:\Users\wjs>npm install -g particle-cli
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
> serialport@3.1.2 install C:\Users\wjs\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
> node-pre-gyp install --fallback-to-build

[serialport] Success: "C:\Users\wjs\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport\build\Release\serialport.node" is installed via remote
C:\Users\wjs\AppData\Roaming\npm\particle -> C:\Users\wjs\AppData\Roaming\npm\node_modules\particle-cli\bin\particle.js
particle-cli@1.17.0 C:\Users\wjs\AppData\Roaming\npm\node_modules\particle-cli
├── xtend@4.0.1
├── semver@5.3.0
├── cli-spinner@0.2.5
├── temp@0.8.3 (os-tmpdir@1.0.2, rimraf@2.2.8)
├── cli-table@0.3.1 (colors@1.0.3)
├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, has-ansi@2.0.0, strip-ansi@3.0.1)
├── node-wifiscanner2@1.2.0 (os-locale@1.4.0)
├── inquirer@0.11.4 (strip-ansi@3.0.1, ansi-regex@2.0.0, ansi-escapes@1.4.0, through@2.3.8, cli-width@1.1.1, figures@1.7.0, rx-lite@3.1.2, cli-cursor@1.0.2, run-async@0.1.0, string-width@1.0.2, readline2@1.0.1)
├── form-data@1.0.0-rc4 (async@1.5.2, mime-types@2.1.12, combined-stream@1.0.5)
├── hogan.js@2.0.0
├── when@3.7.7
├── glob@4.5.3 (inherits@2.0.3, inflight@1.0.6, once@1.4.0, minimatch@2.0.10)
├── binary-version-reader@0.4.0 (buffer-crc32@0.2.5, h5.buffers@0.1.1)
├── lodash@3.10.1
├── request@2.75.0 (is-typedarray@1.0.0, oauth-sign@0.8.2, aws-sign2@0.6.0, forever-agent@0.6.1, tunnel-agent@0.4.3, caseless@0.11.0, stringstream@0.0.5, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, aws4@1.5.0, combined-stream@1.0.5, node-uuid@1.4.7, qs@6.2.1, form-data@2.0.0, mime-types@2.1.12, tough-cookie@2.3.1, har-validator@2.0.6, hawk@3.1.3, bl@1.1.2, http-signature@1.1.1)
├── latest-version@2.0.0 (package-json@2.4.0)
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.30)
├── moment@2.15.2
└── serialport@3.1.2 (bindings@1.2.1, commander@2.9.0, debug@2.2.0, es6-promise@3.3.1, nan@2.4.0, object.assign@4.0.4)


I have tried npm install -g minimatch

What am I missing (apart from v 1.17.0 particle CLI)?


That output looks rather normal to me :wink:
What does

particle --version

give you?

Maybe you want to try npm uninstall -g particle-cli and then try to install again.


Particle --version

npm uninstall -g particle-cli gives

unbuild particle-cli@1.17.0

If I try install I get exactly the same as I have shared above!


That looks as if you have (had) got two instances of CLI and possibly also of node/npm installed.

When you did particle --version the 1.16.0 instance was found first but the npm instance you were executing the uninstall command with obviously rather got 1.17.0 first to remove.

What happens when you execute the uninstall twice?
Can you locate another particle-cli folder after you uninstalled?
Does particle --version still work after you unbuilt 1.17.0?

You can look for particle-cli in





Running uninstall twice takes away the 1.17.0 version only and leaves the 1.16.0 version.

I can see copies in appdata\Local and appdata\Roaming.

Can I just delete these files and start again?

Update: I removed the local version of the files and 1.17.0 was exposed and working! Thanks for the tip about the second version.


This is an FYI:

Norton Internet Security deletes ParticleCLIsetup from my Windows computer when I download it.


Damn paranoid Norton antivirus…


I submitted this as a false positive detection but there’s no indication of how long correction would take.


i went to the website of norton to investigate and found this 7 year old write up .
it seems like a bogus explanation and very poor way to treat companies doing legitimate business.


It should be fixed now. Norton accepted the whitelisting so the Windows CLI installer should not be flagged as a virus now.


FYI: It looks like this problem is back …


Hi. I am pulling my hair out for 3 days trying to install Particle CLI on Windows 7 on 3 different pcs. My internet connection get cutoff while trying to install the cli. Has anyone encountered this problem?
I also tried downloading by tethering my mobile and my wifes mobile via hotspot.
All instances executable hangs, internet gets cut off. Need to restart router again each time to try all over again.
Called my service provider, they seem hopeless! They said since you can download from other secure sources it obviously isn’t our fault!


@eLumaLite are you having problems downloading the CLI installer or having issues running it?


Running it.


I downloaded the setup file but hangs while trying to download and install components


Can you show where it hangs (screenshot)?


Sometimes installing the CLI on a windows machine takes 20+ mins to complete as it downloads and then installs everything. It could take an hour if your internet connection is slow based on my experiences.