P2 Stuck Blinking Yellow

Hi, I have got an issue with two x P2 modules constantly flashing yellow. Both parts were working and connecting to wifi until I updated them to previously working code with the latest prerelease firmware (5.2.0). The download completed without errors and the device was reset. The LED changed colour several times (green, blue and magenta) before flashing yellow. Now the units flash yellow as soon as they are turned on.

I would appreciate any help in recovering these units, eg. clearing image. They do appear to be in DFU mode, as dfu-util does work with the following output

dfu-util -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Cannot open DFU device 17e9:6006
Cannot open DFU device 17e9:6006
Found DFU: [2b04:d020] ver=0252, devnum=65, cfg=1, intf=0, alt=1, name=“@DCT Flash /0x00000000/1016Ke", serial=“0a10aced202…”
Found DFU: [2b04:d020] ver=0252, devnum=65, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/2048
004Kg”, serial=0a10aced202…"

Also “particle usb list” works as expected and returns the unit names and ids. I am not able to put the devices into safe-mode

I cannot get “particle device doctor” to work on the devices. Not sure if this is supported on P2 ?

Device doctor does not work on the P2. You should try using Device Restore USB instead.

If the device goes into DFU mode at boot it’s missing system components so you won’t be able to get into safe mode or listening mode as there is no working system image on the device.

1 Like

Thanks for your help. That worked !

1 Like