Old photons cant get working

photon
Tags: #<Tag:0x00007fe21cf364b0>

#1

I have a couple of photons that I ordered back in november 2014 and promptly put into a drawer and forgot about. Now I have got them out and am trying to get them working.

They are on my wifi, they are showing in the web IDE as devices and I can press on the ! at the bottom and make the light cycle thru a rainbow.

Loading up any of the examples, or even a blank sketch will verify fine, but flash will time out.

Is there something I need to do to get these old boards up to current firmware? It doesnt have a version showing in the web IDE underneith the dropdown for target version like I have seen in screenshots.

Also the android app will not flash tinker to them.


#2

@richms are you sure you don’t have the original Spark Cores instead of Photons? Can you post a picture of one of them?


#3

I’ve found the installer for windows and am giving that a try now. I was looking all thru the web IDE for where to put the commands listed in a few other posts with similar sounding issues.


#4

I guess you are refering to the CLI Installer, right?
Once you have that setup, put your device into DFU Mode and run

particle update

(in Windows Powershell or CMD)

Also make sure that you have the golden star next to the device you want to flash OTA and have a target firmware version selected that’s less or equal to the device OS reported as On the device.
Flashing an application that’s targeted for a version greater will result in an automatic device OS update which will involve several magenta flash/reset cycles you shouldn’t interrupt.


#5

Yes, it was the CLI that i have installed.

While screwing around with it I have powercycled it many many times so may have corrupted something in this one.

Ive tried many things from various threads in DFU mode but they all seem to fail with similar messages.

particle1

Invalid DFU suffix comes up with almost any of the commands.

This is the particle keys doctor command. First is in DFU blinking yellow, second is with it not, so it clealry is starting to do something when in DFU but then it fails with that same suffix error.

I got it to the stage after unclaiming the device and trying to add it again that it was flashing cyan many times then a single red flash and found this thread Using Device Doctor with Photon: Command failed: dfu-util... etcetera so tried the commands in it.

I also end up with a lot of _rsa_new.der, _rsa_new.pub.pem and _rsa_new.pem on the desktop along with some backup files similarly named.

Trying to flash tinker from commandline gets this, first is when in DFU and second is when not in DFU

particle3


#6

If you add the -v switch to these commands you may get better feedback about possible reasons.

That’s an absolute non-issue. It’s just a warning for (hypothetic) future releases of dfu-util.

More disconcerting is the Error during downloade get_status message. But that could be pointing towards a bootloader issue.

Can you post the result of particle serial inspect (Listening Mode)?

Unclaiming usually makes things worse than better, so you’d better not try that as you may not be able to claim the device again when it’s in some intermediate state.


#7

and particle -v update gives a lot of the uploads happening looking sucessful, then this which seems to fail at “Error during download get_status”


#8

PS C:\Users\richard\Desktop> particle serial inspect
Could not get inspect device: Serial timed out

It takes ages before responding with a times out on that command.

I have one serial port in device manager showing as photon serial (com3) on this computer when its plugged in and not in DFU mode, none when in DFU mode so it should be looking at the right serial port.


#9

Is particle --version giving you 1.41.2?
Did you check the “remove drivers” and “install drivers” options?

You can download this https://github.com/particle-iot/device-os/releases/download/v1.1.0/photon-bootloader@1.1.0.bin
And put your Photon in Listening Mode to run particle flash --serial photon-bootloader@1.1.0.bin -v

After that download these two
https://github.com/particle-iot/device-os/releases/download/v1.1.0/photon-system-part1@1.1.0.bin
https://github.com/particle-iot/device-os/releases/download/v1.1.0/photon-system-part2@1.1.0.bin

and apply them in DFU Mode via

particle flash --usb photon_system-part1@1.1.0.bin -v
particle flash --usb photon_system-part2@1.1.0.bin -v
particle flash --usb tinker

If you still get these JS errors, try uninstalling/reinstalling CLI and try again.


#10

I grabbed another particle drivers download which had the uninstall option in it and gave that a shot, it removed them, and then I reinstalled them without error.

Awesome! we have sucess. This time the particle keys doctor and its ID suceeded, the thing is back to a fading cyan and the tinker app is on there and I can flick the relays on and off from the android app!

Just did the web IDE and it was able to flash blink down to it quickly and easily.

Thanks heaps.


#11

Sorry, prematurely posted that. I did all the other steps in the last post from @ScruffR as well. Just somewhat excited to get to have a play with these now :wink:


#12

That often happens to me too :blush:
But you don’t need to create a new post when you realise you want to add/change/remove something.
You can just use the Edit feature (bottom line of your posts image ) for your posts.
If you don’t see that, it may hide behinde the ellipsis image
There you can also find other options (e.g. the Solution checkbox image to mark any - but the opening - post in your thread as the accepted solution).