Not Connecting to WIFI at Office [RESOLVED]

Great. Re-running the patch programmer has definitely helped some people who were still seeing the flashing green issue with otherwise acceptable conditions. Hopefully this gets you online!

We’re aware that some of these start-up bugs can be a pain to deal with–let us know if there’s a way we can improve our documentation to help people who run into issues getting started.

I haven’t had time to troubleshoot my office network. Someone at work suggested I use the same key and wep security at home to make sure I am entering it right into the spark core, as in 64bit/128bit encription ascii vs. hex. So, that is my next thing to try. Or maybe try the CC3000 patch programmer.

Time to revive this topic! I took a little break over the summer but am getting my project going again. Since I last posted we changed our office wifi to wpa2 auto psk and it has a new shorter password. I took my core in today and tried to connect using the tinker app. It still was not able to connect (flashing green the whole time). Connects fine at home and to my phones hotspot. I have yet to try adding the wifi credentials via usb (didn’t work back in March when our wifi was set to WEP with a long password). I started down the path of running the CC3000 patch since I had never done that. But I did do the deep update the other day. Does the deep update include the CC3000 patch or do I still need to apply that?

The deep-update is cc3000 patch with other housekeeping so the answer is yes :slight_smile:

Ok, thanks! What should I try next, setting wifi credentials over usb? This is a small office but I’m afraid that I could be up against a firewall or something.

I haven’t read your previous posts but CC3000 doesn’t allow enterprise network with certificate and requirement to enter username and password etc.

A usual home network using wpa/wpa2 with a password and ssid to connect works great!

What is your office setup like?

Talking to my coworker who set it up he told me it was wpa2 (auto psk). I don’t know what auto psk means and he really didn’t have a clue either. There is no splash screen to connect my phone or laptop I just need the ssid and password and I’m good. What exactly is an enterprise network and how would I know if we had one? No user name involved with connecting to the wifi, just ssid and password. I know we have a sonicwall but I don’t know what that is or does but I think it may have a firewall. I’d like to setup a guest network or test turning off the firewall but don’t want to pester my coworkers just so my remote start will work, haha.

Did the core managed to reach blinking cyan when yoh send in Wifi credentials?

No it continued to blink green.

Wpa-2 auto psk will try wpa2 psk first and if it fails then try wpa psk.

1 Like

Tried somethings today with no success. I setup my wifi at home to wpa2 with the same ssid and password that is used at the office. My phone connect right away with the stored credentials so it thought it was at the office. Using the tinker app I was able to connect the core to wifi. While out and about today pulled into the parking lot at work and had good signal on my phone but the core would not connect, still flashing green.

Would setting wifi credentials over usb be any different than what I just did?

Any other ideas? I thought I read something about a port that I could open up that the core uses to get to the cloud. Maybe that would help.

Side question: If the core is in range of two wifi networks that it has credentials to, does it connect to both simultaneously? I saw the same mac address listed on two different wifi router status pages today and it appears to switch instantly to the other network if the first one it connects to is turned off.

I’ve been reading threads, from before the deep update came out, about fixing blinking green issues by running the CC3000 patch. It sounds like some people had to run the patch several times before having success. Is the deep update ever unsuccessful at patching the CC3000? Is it possible my CC3000 still needs the patch?

blinking green means the core is unable to connect to the Wifi network yet.

You can try patching again but do check the Security type, SSID and password to be correct when you send via USB.

Also, you might be able to figure out the network information using your laptop connected to the Wifi.

Sometimes, the a/b/n setting might cause. the core not to connect.

Back in March when I was troubleshooting this I was using an iPhone 4 which did not have n wifi. So at that time I know our network was capable of wifi other than n so that shouldn’t be the reason.

Other devices work fine but the CC3000 is very particularly about this :confused:

I’m not sure I am following you. I read that the cc3000 doesn’t support, are you saying maybe our wifi is set to N only? Or is there something else you are suggesting I check into?

I just looked up the iPhone 4 I was using back and march and to my surprise it actually supports N (2.4 Ghz only). I’m still convinced we more than N at the office because we have some old laptops running around that came before N was introduced. But I will check.

@pitchlynn the CC3000 usually has no problem connecting to 802.11n networks if it is configured over USB, but the SmartConfig setup process (wireless setup using iPhone/Android) only works on 802.11b/g networks.

1 Like

Will the photon be any better when comes to network connection issues?

I brought my spark core to the office today to try some more ideas and to my surprise I was able to get it to connect to the office wifi after almost a year of failed attempts! I’m so happy to finally be able to put my wifi remote start in use. Plenty of winter left to enjoy using it too. I think what worked was a combination of my office changing from wep to wpa2, new wifi password, deep update to the core, and manually entering the credentials over serial to the core.

Thanks for all the help!


Awesome, nice to hear it’s working! :slight_smile: