New Download feature of Web IDE Doesn't Work Correctly

I just tried out the new feature on the web IDE to download source code. When I open one of the saved files (Dev by default on a mac), I see ~300 folders and files, most of which have nothing to do with my code. It looks like it’s including everything in my downloads folder. If I drag the unzipped file out of Downloads onto my desktop, then dev shows all the files on my desktop. @suda, is there another way I should be opening these saved files?

@Ric, odd. I just tried two projects and it worked just fine - no folders, just the files and a file.

Oh, that’s a combination of a Mac thing and an Atom thing. Unzipping an archive that has just one file, will create the file in the same directory as the ZIP file and if you open a single file in it, it will open the whole parent directory. I’d recommend putting the file in a separate directory and opening it in the Dev.

1 Like

Ok, I tried that. I don’t see the save screen you show in your post (it automatically goes to Downloads). If I move more than one to a new folder, then it opens them both, so it looks like I need to have every one in a separate folder.

1 Like