Mesh Issues with the IDE

This evening, the web IDE came up showing -rc.26 as the default DeviceOS version. But, despite several attempts to flash an updated OS to either Argon or Xenon devices, each time, the OS version does not change and my device reverts back to running Tinker! The only way to load my firmware is to select -rc.25 for the OS and reflash some firmware.

Is anyone else seeing this? A website issue? A bad -rc.26? Shame, as I was hoping for some improvements.

Another web IDE issue: I often get a successful flash notification in the IDE, but a failed notification in the event viewer for the same flash attempt, which did, indeed, fail to flash.

Me too. If I flash with the default selected, something fails, even though it appears to work.
If I select rc.25, it compiles and runs as expected.

Interestingly, one of my Xenons, the gateway on the Ethernet featherwing has rc.26, but none of the others. Yet…

I’m experiencing the same thing - the flash claims success, but the devices revert to Tinker. But changing the upload target to rc.25 seems to make things fine. Have not tried updating the OS’s yet, as I’m away from the devices.

I’m also seeing the same thing, the code reverts to Tinker. Also, now if I try to compile code that worked before, I get a mesh not defined error. I’m also not seeing any serial port for either my Argon or Xenon.

Same here they are all running Tinker now :weary:

Seems like the Web IDE is too excited for rc.26 release and went ahead to display before the compiler knows about this version. :smiley:

Let me check in with the team to see how this can be resolved.

1 Like

Hi all - sorry about this, our automated build systems got a little trigger-happy and rc26 was released to the Web IDE prematurely. We’ve removed it and are looking into steps to revert.


Hi all, I yanked rc.26 from the Web IDE. It was made default unintentionally (we’re still testing it). There is a bug in rc.25 that reflashes Tinker when you try to flash an app compiled against a newer system version. I’m working with the team to figure out the way forward before we release rc.26.

You can reflash your app compiled against rc.25 to keep going.


Looks like this is resolved for now; if anyone sees any further issues with this, please let us know.