Mesh devices requiring a computer to connect correctly

argon
xenon
Tags: #<Tag:0x00007f1ca6846e98> #<Tag:0x00007f1ca6846a60>

#1

Hello everyone,

I’m writing to you in regards the Mesh devices. My setup consists of an Argon gateway and 3 Xenon nodes. All up to date to the latest firmware.
I’ve tried all available resources (at least that’s what I think) to find a solution to my issue, explained just below:

Story:
I’ve added all devices mentioned above to the same Mesh Network. I did it using the Particle CLI because I was not able to achieve the same through the Particle mobile app for Android (don’t know why).
particle-mesh-network
I also flashed the tinker app to all said devices to rule out any issues rendered from my real code.

Issue:
After flashing all devices with the tinker app, unplugging them from my computer and connecting them to a power source different from my computer, Xenon devices no longer connect to the mesh network.
Once I plug them back to the computer, all together, they connect to the mesh network successfully.
I even connected some of the Xenon nodes to a different computer and it worked as expected. With this in mind, I kind of sense they require, somehow, a serial device to work properly because an external power source does not work at all.
Here a link to the video showing this behavior

I’d very much appreciate if someone could give some light on it as given this issue, Mesh devices cannot be deployed and the reliability cannot be guaranteed and ensured Xenon devices will connect correctly to the Mesh network in the outdoor powered by an external source.


#2

You should take your devices out of the anti-static foam.
You may also try some other power source - it might be due to poor power quality of that particular charger.
The quality demands for mere chargers aren’t high so even the noisiest of devices can call themselves “USB chargers” (smart or not).


#3

Thank you for the quick responde @ScruffR. Nonetheless, I have also tried with several charges, good quality ones from smartphones but the result has always been the same.

Do you really think the foam could be the reason behind this issue?


#4

Have you tried it? Removing any - even the unlikely - factors from the equation is always a crucial step in debugging hard to catch issues.

The foam is slightly conductive and in combination with the non-common ground between the devices may affect the reception in that way.


#5

@ScruffR I just did the test. I left the Argon and 2 of the Xenon devices plug to the computer based power source and the remaining Xenon was left on a bread board and powered by a Samsung charger.
Same result, the later Xenon does not connect to the Mesh network and it goes right away blinking blue.


#6

What code is running on the device?


#7

@ScruffR They all are running the Tinker app. I did particle flash --usb tinker with all of them.
Left the Argon and 2 Xenon plugged to the computer and the third Xenon with the Samsung charger. Same result, computer plugged devices connect to the Mesh network whereas the the last Xenon does not.


#8

That’s very strange!

@rickkas7, some idea what that could be?


#9

I know for a little while that the tinker command did not actually pull for mesh devices a little while after release. I believe that should have been corrected since (or was planned).

It may sound strange, but I would consider trying to pull Tinker from the latest release repository for gen 3 and see if that makes any sort of difference in expected behavior. Typically, the Github repo binaries are the source of truth for the cleanest, expected behavior.


#10

Alright @mstanley @ScruffR, I’ll give it try and come back to you guys with my results.


#11

FYI:
The foam is anti static foam. Which means it’s conductive. It’s probably not the cause of your issues. It’s not wise to power the device while inserted in the foam. Same thing applies to anti-static bags. Don’t use a anti static bag for anything other than transportation of your devices.

J.


#12

So guys, @ScruffR @kenco @mstanley, I downloaded the last binary for the Tinker app for the Argon and Xenons from https://github.com/particle-iot/device-os/releases/tag/v0.9.0 and flashed it accordingly. Also, I removed the conductive foam and try my setup again as before. Yet again, I had the same result, the Xenon powered by an external source (Samsung charger) different from the computer did not connect to the Mesh network.


#13

Does this happen to any of your Xenons or only particular devices?
How is it when you move the Xenon further away from the gateway?
Is the device still dropping into Listening Mode (blinking blue) or are you seeing any other colours?
Have you got a close-up video of the issue?


#14

Odd. Does the Xenon connect to the MESH network if you power it from a battery only? Will the Xenons connect when all devices are plugged into that “OVOS” charger? Maybe something in your lab is stomping on the RF signal quality and having a common ground is just making it tolerable enough for a connection.

This is more for the experts that read this thread, but can you read the RSSI between the Argon and the Xenons? Be nice to see if this tanks when he is using an external supply.