Mesh device setup failing with android app [Solved]


I am OK waiting and providing information that can help Particle fix the problem, rather than circumventing it.
I’d like to help improve the out-of-box experience for others.


I’m trying to think of how cos the factory shipped firmware does not have serial debugging output available so there’s a limit to debugging.

Possibly the Android app side can give some insights…

@rickkas7 all yours!


Ah - but it will likely require care to make sure that the Android app still wants to perform the upgrade that it is getting hung up on.


I’ve done this a few more times. I’ve now seen a wider range of places it stops between 6% and 14%. My original thought was that it got through the first upload, rebooted, and then didn’t continue. But now I wonder if it is rebooting in the middle of uploading the first part. I am new to this platform so have no baseline to know how the app or this boot loader works when it succeeds.


I assume there are others experiencing this too.

If you want to make forward progress, you can follow the hint that Kenneth provided above, what is implicit knowledge in that link is that you need to install another tool called the “Particle CLI” (

I’ll try and keep the particle engineers honest by staying here and helping them understand and fix this particular failure mode, feel free to move ahead and put your mesh devices to good use.


The Particle CLI is one work around. Another phone is another workaround suggested by Particle support. They also said they think this is limited to the android client and their app engineer is going to take a look at it. Personally I think they should have discovered this problem through monitoring and had it fixed before many customers ran into it. It makes me wonder if they monitor and maintain their other cloud services or if it is really only squeaky wheel.


Are you suggesting that they monitor your mobile app and be able to watch how the % progress made?

There’s no cloud involvement when a BLE OTA firmware upgrade is performed.

Not trying to say that it’s acceptable for this to happen but I’m sure during testing phase (I did lots of testing too), we did not encounter this situation with a variety of mobile devices. :slight_smile:


It really isn’t that hard of a thing to gather metrics. Generate a beacon when you start, on error, and on success. Seeing a spike in failures is a good clue that you have some work to do. If you can’t do that I really have a hard time believing that you could run any real cloud operation at even the smallest of scales.

Looking back this sounds a bit salty. My intention was to communicate there are ways to improve the developer experience. Particle has some cloud functionality. Monitoring and alerting is part and parcel of running one of those. So I thought it wouldn’t be a big deal to monitor how their tools were working for developers.


Thanks for chiming in here. Indeed, we did not see this issue throughout our testing process and are thankful to individuals in the community for making us aware of the issue.

We’re compiling a list of known issues that will allow us to more easily share and communicate progress with the community and will be sure to include this as a high priority issue given that it disrupts the onboarding experience. More details to come.


In addition to the thread started for tracking issues support responded to me that their Android guru has identified an issue with Android BLE services. Sounds like some progress is being made.


Thanks for this link, it was helpful. But after flashing the update, going into the app again to try to register/setup the device it still tries to update the device OS. Is that what you experienced too? Were you able to setup the device without the app?


At present you can only set up a mesh device using the iOS or Android mobile app.I am not sure why you got the update dialog the second time; I haven’t heard of that.


I’m having the same issues as described in this thread, including the trying to update after I have already updated via USB issue. I am using an LG V20 running Android 8.0.0 and I have the latest Particle app. At some point I did get past the required update screen for my Boron but then it failed on the mesh setup.

I also failed to connect to WiFi (IPv6 is disabled on the router) using my Argon. I tried to configure it after flashing via USB using the USB serial console but no matter what I do I get a rapid green blink.

I’m not very happy about how poor the device setup is. I’m guessing it will improve later but still a bad first impression. The mesh configuration should be able to be completed using a PC so troubleshooting and debug information can be collected easily. If there is a way to put the Andriod app in some sort of debug mode to collect information from it I would be all for doing this. I’m fairly competent with embedded systems but I don’t see a way to get more information out of the required app.

I hope in the next version or two the ability to configure the mesh is added to the serial interface of all gen 3 devices.


Ok so after much beating on things, I figured out how to get the Boron to complete the mesh setup.

Right after entering the mesh network password, but before continuing, hold the MODE button until it starts blinking blue again. Then when you hit continue it completes the setup. Without doing this it never gets past creating the mesh network on the particle cloud.

I also was able to connect a Xenon but that also had failures and took a lot of screwing around until it finally connected to the cloud. However, it kept saying it was failing to claim the device. Manually running the claim using the particle CLI worked but the phone app still was stuck on trying to claim.

In all cases, I had to flash the firmware via USB. That problem I still haven’t found a solution for.


I just received my first two Argons. I am now up and running using them as stand alone nodes but have failed to create a mesh network. Updating the firmware succeds but the android app never became aware, so I needed to abort the upgrade, but after adding the device again the firmware was updated.

I have the been able to add the devices as stand alone noded but when I try to add them to a new mesh network, the process stops after adding the Wifi network and before the device registers to the device cloud.

Any ide on how to force the device to create and join a mesh network?


Argons are by default gateways and currently there are only single-gateway networks supporte.
Hence you cannot add another gateway to an existing network (that’s also true when you removed the original gateway from the network since the concept of a “gatewayless” network is unknown to the system and hence when there already is an existing network any “new” gateway would be treated as additional).

If you want to create a new network you must opt for YES, USE IN MESH NETWORK (Yes, we already have complained about “awkward” choice of wording and that CREATE MESH NETWORK for the first gateway would be clearer :wink: )


After upgrading the firmware to 0.8.0-RC26 adding the Argon as a gateway to a new network nworks as a charm.



Have been travelling for $DAYJOB this week, will perform the wired upgrade to RC26 this weekend and report back.



I updated the firmware on my Argon & Xenons via USB and the particle cli instructions.

After a false start where I tried to bring up a xenon without a mesh network within range (so I created a mesh network by claiming and configuring the argon first) - I was able to add 2 xenons to the mesh network - all using my LG G5 phone.

I exited the setup process at this point and tested these parts using the app to twiddle D7 on all 3 devices.
So far so good.

I go back to add more xenons to the mesh and now after I select the mesh network, I get this screen instead of the one where it says “joining the mesh network” etc etc:

The xenon is already flashing blue at this point, and continuing to scan the 2D barcode doesn’t help at all.

I’m a little baffled what backwater of the process that I’ve got stuck in, it seems like when I claimed and configured the first two xenons, I was in a mode where the app had maybe cached some info, and that got lost when I exited to toggle bits using tinker.

Maybe this is intended behavior - I’m not sure why the flow is different from the first two xenons I configured, but I’m unclear how to proceed.

LG5 not pairing with Argon or Xenon

What I had to do is put an already existing xenon node into listening mode and scan that bar code. Some sort of extra security I guess, whereby the already enmeshed xenon pairs up with the new one.