Login to Particle Cloud on Desktop IDE "mfa_required" error


#1

When I try to log into the Particle Cloud in Desktop IDE I get the error, “mfa_required”. I logged out to try to solve the issue where no devices load and when I went to log back in I got this error. Any guidance would be appreciated. Thanks

I disabled MFA and was able to log in. What is the process to log in via Desktop IDE when MFA is turned on?


#2

The current desktop IDE does not support MFA and there are no plans to as we are moving to the recently announced Particle Workbench as our mainline desktop solution.


#3

@samt, will the new Particle Workbench support MFA or will we need to disable two-factor on our accounts?

Doug


#4

The objective is to log in from Desktop IDE , witch is filling with error saying MFA is required. So are you saying desktop IDE is not supported anymore ?


So is desktop ide supported or not?
#5

Currently there still are two desktop IDEs: Particle Dev and Particle Workbench. As mentioned above, support for Particle Dev will be phased out in favor of Workbench. As such, MFA won’t become available for Dev anymore.


#6

So how do I log in if it is still supported


#7

I’d say the answer if you asked support crew would be: “You can’t and won’t be. T/MFA is a new feature that came after development for Desktop IDE was stopped. You either need to move to Workbench or deactivate T/MFA”.


#8

Ok thanks

So is developer workbench released yet ? I didn’t see it mentioned in the documentation as a dev option . I found an announcement of its future release.


#9

#10

I have the same problem. How can I disable the MFA in Windows 8.1?
Thanks


#11

Thanks for this Info.
Shouldn’t this be mentioned when enabling mfa ?

So i have to disable mfa because i am using atom and i am happy with it

Andreas


#12

How do i deactivate T/MFA to keep using the desktop IDE ?


#13

You can turn on or off MFA from:

https://login.particle.io/account-info

You can also log into https://console.particle.io and use the Edit Account item in the popup menu with your email address in the upper right corner of the console.


#14

Both methods have the same messages - “Could not validate OTP” - ???


#15

Problem solved. Had to dug out my old phone and with old simcard and then the code worked.