[ISSUE] 'chownr' Error Message on Create New Project

I have an error message I can’t find referenced any where online. I have a student that installed Particle Workbench on her laptop. It got stuck installing Particle Dependencies, then I had her install the CLI using the standalone CLI installer. Everything appeared to install without error.

Now when she creates a new Project, after selecting the working folder and giving it a project name she gets an error message stating:
Cannot find module ‘chownr’

Any one seen this or know how to fixed the missing dependency?

Thanks,
David Orser

i’ve never seen that error before. one thing to try is to run the Particle: Reset Environment otherwise, we’ll need some more info to help troubleshoot:

Thanks, I’ll try that next. As it is a student computer, the debugging loop is going to be rather long.

I’ve noticed several students getting a message during dependency install about it failing. However it doesn’t give any further info/details.

Is there a log file that I can open that shows what failed in the Dependencies Install?

What other directories could be wiped after an uninstall besides ~/.vscode to provide a clean re-install?

chownr is a CLI dependency - they probably cancelled the install mid-way through or something hiccup’ed along the way. best bet is a manual reset :point_right: How to manually reset your CLI installation

Ok, we tried both suggestions above (>Particle: Reset Env. and Manual CLI reset). Neither worked.

However, when we were creating projects at the end of the above process a short duration notification box flashed by saying, “chown was blocked from editing a file in your Documents directory”. Digging a little bit, we found the program Bit Defender was blocking a variety of programs from accessing the Documents Folder, including node.js, mkdir, and other programs that both the “create project” and compile scripts were calling.

We found two options for fixing this problem:
1.) Move the project folder to c:\RandomDirName and everything works fine.

2.) Talk to someone you trust about computer security and potentially remove or replace the security program Bit Defender.

What a pain! Thanks for the options you provided.

Best,
–David

1 Like

One more quick update. I have had two more students with Workbench installs that have been corrupted by anti-virus programs. These students each had node.exe removed by the anti-virus program.

For the record that makes about 3 students out of around 120. I only detected the last two cases due to the online-only course model (until now the students had silently given up on fixing their own computers and resorted to using University Computers labs, which are no longer available.) It is not a huge percentage but approaching a point you may want to address it.

I’m not sure why this install method is being picked apart by anti-virus programs, but perhaps it’s worth looking at relocating executables to a different install location?