Infinite redirect loop when visiting http://build.particle.io/build


#1

I just created a new account and went to http://build.particle.io/build to set up Particle Web IDE as described https://docs.particle.io/tutorials/hardware-projects/maker-kit/.

Any thoughts?


#2

Update: I’m able to reach the build page in incognito.


#3

Try: build.particle.io, without the additional “/build” on the end. Following your link gave me an infinite loop as well. Strange behavior, but dropping the last bit took care of it for me.


#4

Same here, I can’t access http://build.particle.io/build or http://build.particle.io/, normal or incognito


#5

I’m seeing the same issue. Using chrome or firefox I can log into the console but visiting build.particle.io in any fashion (including incognito mode) takes me to build.particle.io/authenticate then to https://login.particle.io/login?redirect=http://build.particle.io/build and then to http://build.particle.io/build then back to login. I can switch to microsoft edge and it works as expected.


#6

Hi @trackdork

I run Firefox 65.0.2 64-bit on Windows here at work and I just tried to log in to build.particle.io and it worked fine for me.

You might check to see if your Firefox has a proxy or other setup item that could cause this.


#7

This is still an issue. It doesn’t work on Chrome at least on 2 different computers. @bko
I don’t use proxy or VPN
Firefox works, but my main browser is Chrome


#8

Tried Edge as well. I never ever used this browser for particle. Also gives redirect loop.


#9

I have chrome on Mac - I enter build.particle.io and it opens https://build.particle.io/build/new. you seem to have some issue not related to a pc pc/browser. ahem you created a new account to test this?


#10

The root cause is not yet known, but a contributing factor is that the https:// URL is redirecting to an http:// address.
You can try copying the entire URL (that starts the loop) and change the redirect to https:// and see if this changes something.

This will start the loop:
https://login.particle.io/login?redirect=http://build.particle.io/build
This won’t:
https://login.particle.io/login?redirect=https://build.particle.io/build

One suspicion is that some browser cookie or other persistent setting on your machinge causes the wrong redirect. Once breaking that cycle should help cure the issue.


#11

This looks to be working. That looks like an easy fix for a developer to adjust redirect automatically. Why do you even use http in 2019?


#12

That’s exactly what’s not fully understood where that http:// comes from. It shouldn’t be there as far the web crew is concerned. It must be hinding in some of the cracks resisting fumigation :wink:


#13

I’m still seeing that as an easy fix. If you get ‘http’ in ‘redirect=’ just replace it with https xD