HowTo: Solve USB connection issue on Macbook Air (Mid 2011)

Heya Spark community!

I just solved an issue that made me headaches over a month - so here we go with sharing the solution to help you avoid similar pain :smile:

I’m working on multiple OSX platforms. While the Spark gets detected on my iMac and Macbook Pro, it never showed up as a serial device on my Macbook Air (Mid 2011), neither on OSX 10.9 nor on the latest beta of 10.10.

Whyever it is related to this specific model, installing following FTDI driver made it work:

Finally I can configure + serial monitor the spark on the Macbook Air, yey!

Hope this may help anyone with a similar problem,
best and thanks for this lovely community + amazing product,

  • Michael

Hi @rastapasta,

Awesome, I haven’t seen that one, thanks!


I really thought this was going to solve my problem :frowning:
Im using a Macbook Pro Retina 2014. And I just can’t make it detect the core in any USB port, even by attaching a USB 2.0 Hub. And I’ve tried in many different Macbook Pros Retina 2014, because at school all my classmates have the same computer.