How to get a refund?


I’m in London, UK and I’ve been unsuccessfull in setting up my core and wasted too much time on it - how do I go about getting a refund? I couldn’t see anything on the site to help me do this.


Hey @nchaud,

I’m not sure if refund is an option but we cwn definitely help you to work on it :slight_smile:

What problem are you facing?

What colours are the RGB flashing?

Chip or u.fl?

Unless this is a product that’s in the exceptions category, I believe I’m legally entitled to a refund


I’m not saying it’s not possible but we just need to check with @steph and @teke.

You will hear from them but we are always ready to help you troubleshoot :slight_smile:

nchaud, I understand your frustration and I will be the first to advocate for your refund. Strangely, however, this weekend it was discovered that the default settings for the wifi chip prevents it from connecting to European routers set to channels higher than 11!

Perhaps this is what is giving you so much frustration. The good news is that there is a fix! If you are willing to be patient just a little longer, we may be able to resolve the issue.

Whatever your decision, I am sorry your experience to date has been soured.

Ok, that’s fine but could you pls give me a hard date for when it will be. Also, will that mean I’ll need to exchange the chip?


I will work to get you a date though Spark (and I) are traveling today.

You will not have to change anything on your Spark as this is a firmware fix. I appreciate your patience :slight_smile:

1 Like

Ok great. I appreciate your responsiveness :slight_smile:


@nchaud, just to keep you updated, we are working on getting the “fix” evaluated and put into the core firmware. I will update you when I get more news. :smile:

Great, tx…

@nchaud, another update. I seems the proposed firmware change for getting the wifi module to “listen” for channels 12 & 13 (in Europe) may not play well with the CC3000. We are now looking at a one-time change to the CC3000 firmware as part of a (soon to be released) patch from Texas Instruments. If you have any questions, please don’t hesitate.

BTW, there are other ways to test your core that get around the potential router problems. It may be possible, if your phone supports it, to use the wifi hotspot feature of your phone to connect your Core so at least we know it is working. If you would like to do this, let me know :smile:

there is also a fun backstory as to how we figured this out. the spark team had a large booth at maker faire last weekend. in the past, all wifi demos failed, because there is a TON of RF interference at the fair. i offered up the idea to switch all the spark cores to channel 13, since its a european channel, we knew that no one else at maker faire would be using it.
long story, but we got the sparks to eventually play nicely on the european channels, but it made us realize that TI didnt make it easy!

thanks for your patience on this one. the more issues we resolve, the better the product is for everyone.


Indeed was a smart move and we had working demos when the RF interference reduced in the late afternoon.

I was happily switching the incandescent bulb on the GIANT CORE over the internet :smiley:

1 Like

Is this at all similar to an issue I had with my Sparks that just arrived?

I’m based in the UK, and use a BT HomeHub (Version 3 I believe). This is set to WPA/WPA2 by default.

My Spark just plain refused to connect to it using the basic protocol you’ve described in your ‘getting started’ pages and my iPhone - it would continually flash green, with about 1 second of cyan, then back to green.

So I decided to try connecting over USB. Used screen on my mac to connect, and selected WPA2 - no dice. Held down MODE and reset the thing and got back into it with USB again and selected WPA this time and bingo! It worked, and keeps working.

Would any of the experts here know why it can only connect to a WPA/WPA2 network if I manually select WPA, not WPA2 and furthermore why the default pairing routine also refused to work?

A wild guess would be the WPA2 settings IMO.

If you’re interested, do a WPA2 only option on your router and see if the core would connect using WPA2.

I’m glad you got it working!

Are you going to change your instructions for ‘getting started’ so that other UK users don’t have to experience this same issue? BT HomeHubs are very widely used across the UK (32% market share) and come with WPA/WPA2 selected as standard.

If you could test it out and it works, we can definitely change the docs since some/most router might have the WPA/WPA2 option.

We have many variations for Wifi environment and our documentation suggests to keep to the basic setup for the start.


@NanoAkron, that is an interesting find and MAY be what is affecting @nchaud. It may also be that his router is set for a channel higher than 11 (eg. 13). Either way, it may be a good idea for him to try your approach!

1 Like

OK sure, I’ll give it a go with WPA2 tomorrow.


1 Like

Hmm…I held down MODE for 10 seconds to clear the previous WIFI details and it seemed to connect first time when using the Smart Config process. Then tried a factory reset, and it was still able to connect using Smart Config.

All without changing the default from WPA/WPA2. However, the WIFI is currently using Channel 1. I didn’t think to check what channel it had selected the time I had to connect using USB and select WPA.

Sorry I can’t recreate this issue in order to troubleshoot further.