How to fix Green LED issue?

Alright, I am facing couple of strange issues. I have two cores both are having their own issues.

Core 1

  • It’s successfully installed on Windows (including Spark driver) and Mac
  • When I setup wifi it shows green LED
  • I applied cc3000 patch and tinker but no luck
  • Tried iPhone app it only showed once SSID and it setup the wifi details but again all it was flashing green LED.

Core 2:

  • Windows system does not recognize this core. I installed all drivers but it says device can’t start. Tested on Mac but got same results.
  • After getting plenty of times annoying errors from an iPhone app “Smart Config error You must be connected to a Wi-Fi network to connect your core” I finally saw SSID (I swear I didn’t do anything!). The wifi setup was successfully completed.
  • I reset core to factory settings and now I can’t get it back to working
  • I have tried applying cc3000-patch but it says there is no device. I used dfu-util and spark cli

At the minute, I am only concerned about Core 1. Can anyone tell me how to fix this green LED issue?

1.) How did you perform the patch and where is the cc3000 patch binary downloaded from?

2.) Try setting up a hotspot on your iPhone and use Serial to send in your wifi credentials. This can help to determine if the Wifi setup has some issues.

3.) You should be able to enter listening mode again by holding on MODE button for 4 seconds if there’s a need to re-enter Wifi credentials

As for iphone, there might be a chance it’s connected to the 5.0Ghz channel if your router has enabled it and cause some issues using Smart config.