How do you install Electron USB Serial in VMWare workstation with Ubuntu 16.04 as guest?


My development environment is using vmware workstation 14 and guest OS is Ubuntu 16.04. When I tried to flash my electron in ubuntu 16.04. It said device must be connected usb. I have run command ‘ls -al /dev’ and I could not ttyACM0. Any advice would be helpful?

It could be /dev/ttyS# where # is the number reported by your host OS.

You did enable USB pass-through in VMWare for the Electron, correct? Otherwise the host operating system has control over the device instead of the guest operating system.


I did enable USB pass-through by selecting “Connect (Disconnect from Host)” submenu from Removable Devices main menu. Once I have done that and then I ran lsusb and I can see the Realtek appear in the lsusb’s list but nothing like ttyACM* appeared. Did I miss anything?

Ubuntu finally can recognize the Electron USB Serial. The reason earlier that it could not found USB because I was selecting the wrong USB in VMware. All good now. Thanks @rickkas7.