Help! Long filename has broken the webIDE!

Well, sort of.
So, I was going to add a library and since this is like lib #6 in my project, once I clicked the plus sign, the name tab was off the screen, assuming the ide would use a default name or something, I clicked in the body and pasted the lib. Well, that pasted the contents of the lib into the filename. Now the tab is so long, I can’t get to it (I tried dragging the window of the side of the screen and enlarging 10x or so, but that wasn’t enough. Furthermore, the file browser in the last pane doesn’t let you delete files, so now I can’t delete this lib or add any new ones.

Is there anyway to nuke this file? Can someone at spark help me out?

On a related note, it would be awesome if there was an export/import, cause then I would export all of the files, clean them up and import the correct ones back in. Maybe a suggestion for the next sprint.

1 Like

I think you could open up firebug, figure out the tab’s icon and then call it via the firebug console. e.g. this just worked but (jquery, which is used on the spark build IDE):


Or… maybe quicker: copy the main code and simply remove the old app and recreate.

Hi @billprozac,

If you open the code drawer on the left, can you select the filename there?

Also if you email us at from your email account that you use for the build site, and the url of your project, we can help fix the filename.

Also I’m logging a bug for this. :smile:


Thanks guys, I was able to exec the js click event and delete the file.

1 Like