Flashing from workbench shows successful, but nothing happens on the e-series

Hey,
So i am compiling a simple programm in workbench

void setup(){
    pinMode(D4,OUTPUT);
    digitalWrite(D4, LOW);
}
void loop(){
}

Afterwards I flash it. I tried using both usb and seriel. Both show that they are successful. But when I measure the voltage over D4 it is just floating somewhere around 1.7V. I tried it with some Serial.println(). Opened the seriel monitor and nothing is showing. To use the E-Series dev board I used electron as platform. With CLI I can find my board connected to the right com port, it all seems to flash properly, but afterwards nothing seems to work.
Btw. the board is not connected to the cloud. Is that the problem?

Thanks

Yes, it is.
If you are not using a non-AUTOMATIC system mode (or SYSTEM_THREAD(ENABLED)) the device will always try to establish the cloud connection before executing your code (with the exception of code provided via the STARTUP() macro).

Okay,
How can I change this?

I checked binary:

CRC is ok (a68e5077)
 Compiled for electron
 This is an application module number 1 at version 6
 It depends on a system module number 2 at version 1406

this implies, you can change that by using a non-AUTOMATIC (i.e. MANUAL or SEMI_AUTOMATIC) mode and/or using SYSTEM_MODE(ENABLED)

The docs do usually provide some guidance :wink:
https://docs.particle.io/reference/device-os/firmware/electron/#system-modes
https://docs.particle.io/reference/device-os/firmware/electron/#system-thread

Oh man,
thanks. Now it is working. Great advice with great speed.

1 Like