Firmware start fails after power up half of the time, but works fine after reset

About 30 to 50% of the power up cycle by plugging the USB cable I only get a Flashing blue (Smart Config, waiting for Wi-Fi credentials). But when I press the reset button for a second after waiting about 10 sec I get a proper start within 3 seconds and my firmware runs fine. Should be more reliable. Any idea?
Configuration: Spark Core with u.fl antenna on breadboard, powered with laptop USB

@mf2105 This is unique and I’m not able to re-create this behavior on my end. There is no reason for the Core to go into smart config mode if the WiFi credentials already exist. Is there anything else connected to the Core? Whats the user code that you are running?
Another thing to try: Factory reset the Core, connect to WiFi and Reflash Tinker using the iPhone app. The Core should consistently connect to WiFi even after power cycles.

No, there’s nothing connected, only a core on a breadboard, connected with the USB cable (the delivered one) to the laptop. the code is only a modified example to flash the LED at D7 and write the Millis() to Serial (same behaviour w/o serial code line). These are my first steps on Arduino Coding :smiley:
// Program to blink an LED connected to pin D7
// of the Spark Core.

// We name pin D7 as led
int led = D7;

// This routine runs only once upon reset
void setup()
// Initialize D7 pin as output
pinMode(led, OUTPUT);

// This routine loops forever
void loop()
digitalWrite(led, HIGH); // Turn ON the LED
delay(1000); // Wait for 1000mS = 1 second
digitalWrite(led, LOW); // Turn OFF the LED
delay(2000); // Wait for 2 seconds
Serial.print("test ");
Serial.println(millis()); //print timer serial

I can’t reset it with the iphone app, because I only have a Nokia Symbian Smartphone. (by the way: Does the Android version work on an Amazon Kindle? Would be nice for Home Automation, the intended use for my Spark Cores). I will try the factory reset later this night and will come back to this thread after testing.

Factory Reset done, but strange at the end : No LED at all after reset seems done (dark!). Power cycling, starts ok, put back the SSID via USB serial, seems to connect. Flashing from Build was ok, but did not restart, had to press Reset button. Seems to work. After that I tested power cycling 12 times: 3 times ok, 4 = flashing green forever, 5 to 8 = ok, 9 and 10 flashing green forever (tried reset, then ok), 11 and 12 ok. Flashing blue did not appear any longer, but still not reliable… What do you think about ?

Hi @mf2105 ,

Hmm. So the core has connected successfully and isn’t reverting into listening mode (flashing blue). This sounds like the firmware you have is good, and the configuration on the core is also good. If the core is unable to connect to wifi, lets try reducing the number of variables. If you’re up for it, can we try changing a few things and see if that makes the startup more reliable? If the u.fl antenna you’re using is loose or installed strangely it could cause issues. If you haven’t already, can you check how your antenna is installed (make sure it’s snapped firmly on), and / or post the antenna you’re using?

It’s also possible the usb cable could be bad (which another user just reported). Could you try swapping cables and powering over a cell phone charger? The core might not be able to draw enough power from your laptop.

A very small number of users have also seen manufacturing quirks in the breadboards. Could you try removing the core from the breadboard and seeing if that changes things as well?


took it out of the breadboard and tried some power cycles with another USBport at laptop (2Amp out): 1 ok, 2 flashing blue (but ok after reset), 3 ok, 4 flashing green (but ok after pressing reset), 5, 6, 7, 8 ok, 9=2, 10=4 (but needs 2 resets!), 11,12,13 ok, 14=4, 15=4.
Another USB cable from another spark core showed about the same results (except no more 2). I will try with another power supply asap and come back.