Electron not waking


#1

We have 10 Electron running firmware v0.7.0.
Half off them will not wake up at all after calling: System.sleep(SLEEP_MODE_SOFTPOWEROFF, SLEEP_TIME).
Using:
SYSTEM_MODE(SEMI_AUTOMATIC);
SYSTEM_THREAD(ENABLED);

I find it hard to reproduce the error as it affects only half off our fleet.
I know there might be several reasons to this error and I don’t give a lot of information here, but I would like help to narrow down the reason for this happening.


#2

Is SLEEP_TIME a constant? If not, double check that it never gets negative.

Make sure the WKP pin is not HIGH when going to sleep.


#3

What to do if the design has WKP pulled high and the device is put in sleep mode? Is there a work around (such as setting as an output and driving low?)


#4

This is an open issue

While this issue is still slated for 0.8.0 I can’t see a fix applied up to now (0.8.0-rc.9).

Currently the only thing around is to not have it HIGH on sleep.


#5

Thank you - well noted for future designs.


#6

Thank you for the response.
Is there any workarounds for this problem?
I’m using an modified version of the Asset Tracker, where I need to wake on movement.

Does any example code for how to make sure the LIS3DH is not keeping the WKP High before going to sleep exist?


#7

Found a couple of answers here if anyone is interested. asset-tracker-accelerometer-gps-problem

The fix is basicly to check for movement and if there is movement don’t use SLEEP_MODE_DEEP and SLEEP_NETWORK_STANDBY.