Device ownership failure


I’m from holland and for a school project i have to use a internet button.
The internet button has been setup before, i’ve tried to setup the button again with my own name etc. Every time i want to setup the button everything is going smooth in the setup on my iphone but at the last check verify product ownership it goes wrong.

I have setup a button before on my account so i thought maybe that’s the problem so i wanted to delete the device in the terminal. But when i want do delete my device i get this;

‘Didn’t remove the device Permission Denied’

Does anyone has any idea what i can do to fix this?

Usually the previous owner needs to unclaim the device or has to agree with a transfer of ownership.

Does your device get into breathing cyan state (cloud connected)?
This is an important bit in order to get a device claimed to you.

You can claim a device in multiple ways (mobile app, Web IDE, CLI).
I’d recommend using CLI since that’s a good tool to have anyway.
Once you’ve got that installed, you can use particle identify to get the device ID and then use

particle device add <yourDeviceID>

to claim the device, if you get any previous owner info, just post that here

Thanks for the tip!

The button doesn’t go in the cyan mode because he gave me the ownership failure…
If i do the tip from you i get this:
Failed to claim device, server said: Device is not connected

The ownership and the ability to connect to the cloud are two independent things.
You first need to get the device connected in order to be able to claim it.
So I guess your troubles are not actually the transfer of ownership, but that your device can’t connect to the cloud.

Try to clear the WiFi credentials on the device by holding down SETUP for 10+ seconds till the RGB LED starts flashing blue quickly.

What OS have you got on your computer?
Have you CLI installed?
Can you connect the device via USB?

I’ve already reset the button to factory settings and tried to connect trough the USB. I am running the latest version of osx and already tried to connect with CLI…

I’m not surprised that you got the permission denied for removing the device, if you hadn’t already claimed it.
What does particle list give you?

Your second screenshot suggests that your devcie has made it to breathing cyan.
Is that true?

If it’s not breathing cyan, don’t bother claiming/unclaiming, just get the connection sorted first.

1 Like