Connecting Through A Secondary Modem Switch

A picture is attached of my net configuration.

I want to isolate my cores from my primary wireless network. I have added a DLink DIR 655 wireless point set up as a switch, talking to the main DLink. I am looking for skilled advice.

I HAVE (ONCE!) got cores attached to the switch, and ONCE down loaded application code, but encountered lots of problems. That was days past, and now I have been concentrating on stabilizing my knowledge. I have cores operating with the primary modem, so now my skills are somewhat ok. Can you predict any fatal issues I may have attempting to communicate through two modems using this method???

Thanks for the advice.

I have done the same setup and it seemed to work, well almost work.
I made this setup because I wanted to sniff what my wireless router was sending over the Internet when the core tries to connect to the Cloud. I am doing this because my core could not connect to the Cloud.
Note that whether I connect to the first wireless AP or the second, everything occurs the same.
The only issue, is that you have to keep resetting your core’s wifi credentials everytime you switch from one to the other.

Thanks for the confidence. I invested hours having errors on modem 2. ALL of that interface was connected using the iPhone. I have stopped using the phone, now exclusively use USB. I may try again as a test because I really want to have the network segregated. Maybe tomorrow.


I am not sure what you meant by ‘No security’ on your diagram, but I should warn you that I think the core only likes WAP2. I have seen many references to that, and I could not get WEP working.

NO Security…
Yes, WEP caused problems.

Modem 1 has #3 WPA2 and a PW. Cores currently connected. Actually, connected for 3 hours without a RST needed.

Modem #2 is configured with NO SECURITY, NO PW. My iPhone was causing me issues when a PW was required. Some day I will try again, just too confusing for now.

I think I also saw on the forum somewhere that the core/cloud don’t work well if no PW is used.
Why not set up your modem 2 just like your modem 1?

It’s not a second modem you have but a second router. The problem is most likely a double NAT issue. Your cable modem only provides a single IP address to the internet. Your router uses something called NAT or Network Address Translation to allow multiple internal IPs on your LAN to use that single public IP address. When you hooked router 2 up to router 1 the devices on 2 are going through NAT twice, which doesn’t work for a lot of things.

The solution would be to disable the routing functions on router 2 (turn off NAT and DHCP) so that it only functions as a wireless access point.

Let me know if this solves it for you. :smile:

1 Like

timb… thanks for the details (one Comcast modem, two DLink routers). I am hoping the solution is not what you suggest.

I have had success connecting and loading application FW through the two routers. So I am anticipating that when my knowledge is more comfortable, and the CFOD is repaired, I will succeed with the configuration again.

I am hoping the SPARK team also understands the NAT type issues and will recommend an opinion if the connection through the double router will work, before I go through a lot of useless effort.


Hi @LZHenry,

Double NAT shouldn’t be an issue provided that the networking equipment is working properly. Essentially all the core is doing is opening and maintaining a TCP socket to the cloud. So if anything on your network can open and hold a socket on that port, then the core(s) should work fine. :smile: